summaryrefslogtreecommitdiff
path: root/tests/Makefile
diff options
context:
space:
mode:
authorDaniel King <damaki.gh@gmail.com>2016-05-16 18:25:45 -0300
committerManuel Pégourié-Gonnard <manuel.pegourie-gonnard@arm.com>2018-05-24 13:37:31 +0200
commitadc32c0b507e706b076b0978d63d8c5d99cbd474 (patch)
tree0b3f8d98300caa685fd5cda3cfa1db56465ff486 /tests/Makefile
parentbd92062269997a882e6214360da21307fc0bae9b (diff)
Add Poly1305 authenticator algorithm (RFC 7539)
Test vectors are included from RFC 7539. Poly1305 is also added to the benchmark program.
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile b/tests/Makefile
index 34a0a891..90b2028f 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -82,6 +82,7 @@ APPS = test_suite_aes.ecb$(EXEXT) test_suite_aes.cbc$(EXEXT) \
test_suite_pkcs1_v21$(EXEXT) test_suite_pkcs5$(EXEXT) \
test_suite_pkparse$(EXEXT) test_suite_pkwrite$(EXEXT) \
test_suite_pk$(EXEXT) \
+ test_suite_poly1305$(EXEXT) \
test_suite_rsa$(EXEXT) test_suite_shax$(EXEXT) \
test_suite_ssl$(EXEXT) test_suite_timing$(EXEXT) \
test_suite_x509parse$(EXEXT) test_suite_x509write$(EXEXT) \
@@ -414,6 +415,10 @@ test_suite_pk$(EXEXT): test_suite_pk.c $(DEP)
echo " CC $<"
$(CC) $(LOCAL_CFLAGS) $(CFLAGS) $< $(LOCAL_LDFLAGS) $(LDFLAGS) -o $@
+test_suite_poly1305$(EXEXT): test_suite_poly1305.c $(DEP)
+ echo " CC $<"
+ $(CC) $(LOCAL_CFLAGS) $(CFLAGS) $< $(LOCAL_LDFLAGS) $(LDFLAGS) -o $@
+
test_suite_rsa$(EXEXT): test_suite_rsa.c $(DEP)
echo " CC $<"
$(CC) $(LOCAL_CFLAGS) $(CFLAGS) $< $(LOCAL_LDFLAGS) $(LDFLAGS) -o $@