summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Henrique Lima Melara <charlesmelara@outlook.com>2020-07-08 20:47:19 +0200
committerAndrej Shadura <andrewsh@debian.org>2020-07-08 20:47:19 +0200
commit6f632f666a94603a54cb4a3f88c0b90a03297bfb (patch)
tree3a05c4e8f8bb566da0e8baf5a256194794e6fe3b /CMakeLists.txt
parent35e50b0a8ae06793eb2f46e136b76849ef3cfb09 (diff)
Remove unneeded files installation and update appstream location
Last-Update: 2020-06-27 Gbp-Pq: Name 040_fix-makefile.patch
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be6e864..ad76b03 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,10 +53,6 @@ FOREACH(subdir handbook)
ENDFOREACH(ext)
ENDFOREACH(subdir)
-# Install manual page(s)
-FILE(GLOB man doc/man/*)
-INSTALL(FILES ${man} DESTINATION share/man/man1)
-
# Install demonstration project files
FILE(GLOB demo demo/*)
INSTALL(FILES ${demo} DESTINATION ${target_installation_directory}/demo)
@@ -72,7 +68,7 @@ INSTALL(FILES ${translations} DESTINATION ${target_installation_directory}/trans
# Install .desktop spec and application icon
INSTALL(FILES mcu8051ide.png DESTINATION share/pixmaps/)
INSTALL(FILES mcu8051ide.desktop DESTINATION share/applications/)
-INSTALL(FILES mcu8051ide.appdata.xml DESTINATION share/appdata/)
+INSTALL(FILES mcu8051ide.appdata.xml DESTINATION share/metainfo/)
INSTALL(FILES application-x-mcu8051ide.xml DESTINATION share/mime/packages/)
# Install launcher
@@ -84,9 +80,3 @@ INSTALL(
OWNER_WRITE OWNER_READ OWNER_EXECUTE
GROUP_EXECUTE GROUP_READ
)
-
-# Install misc. files
-INSTALL(
- FILES ChangeLog LICENSE
- DESTINATION ${target_installation_directory}
-)