summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFabricio Alcalde <f@lcald.com.ar>2010-07-04 17:14:04 +0000
committerAndrej Shadura <andrewsh@debian.org>2018-05-08 15:59:30 +0200
commit9ac60f8220b3fc4dfe973dfd97b6b7a05a76ae72 (patch)
treebea555e46de20c33aaa3b0ce1a5fc2ce8f5cf1ed /debian/rules
parent5b8466f7fae0e071c0f4eda13051c93313910028 (diff)
Import Debian changes 1.3.7-1
mcu8051ide (1.3.7-1) unstable; urgency=low * Initial release (Closes: #546549) * This is my first Debian package.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules48
1 files changed, 48 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ef5b18b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,48 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ #Nothing to do
+ dh_testdir
+ touch build-stamp
+
+binary: binary-arch binary-indep
+
+binary-arch: build
+ #Nothing to do
+
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_prep
+
+ #Install files
+ dh_install -Xlicence
+ dh_installdocs
+ dh_installmenu
+ dh_installman
+ dh_installchangelogs
+ dh_link
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+.PHONY: build clean binary-indep binary-arch binary