summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source2
-rw-r--r--debian/changelog7
-rw-r--r--debian/control25
-rw-r--r--debian/mcu8051ide.113
-rw-r--r--debian/mcu8051ide.install9
-rw-r--r--debian/patches/addlaunchscript.patch9
-rw-r--r--debian/patches/debian-changes-1.3.7-142
-rw-r--r--debian/patches/fixdesktopfile.patch23
-rw-r--r--debian/patches/series3
-rwxr-xr-xdebian/rules5
-rw-r--r--debian/watch21
11 files changed, 73 insertions, 86 deletions
diff --git a/debian/README.source b/debian/README.source
index 889d1ea..5191129 100644
--- a/debian/README.source
+++ b/debian/README.source
@@ -4,3 +4,5 @@ mcu8051ide for Debian
CMAKE isn't used because nothing is compiled. Instead all files are copied
with the dh_install script.
+
+
diff --git a/debian/changelog b/debian/changelog
index c228a78..374c77f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+mcu8051ide (1.4.7-1) unstable; urgency=low
+
+ * New upstream release.
+ * Fixed spelling error in the manpage.
+
+ -- Fabricio Alcalde <f@lcald.com.ar> Sat, 27 Apr 2013 15:40:07 +0000
+
mcu8051ide (1.3.7-1) unstable; urgency=low
* Initial release (Closes: #546549)
diff --git a/debian/control b/debian/control
index 4ed9b1e..5c6bbd6 100644
--- a/debian/control
+++ b/debian/control
@@ -3,22 +3,15 @@ Section: electronics
Priority: extra
Maintainer: Fabricio Alcalde <f@lcald.com.ar>
Build-Depends: debhelper (>= 7.0.50~)
-Standards-Version: 3.9.0
-Homepage: http://mcu8051ide.sourceforge.net/
-#Vcs-Git: git://git.debian.org/collab-maint/mcu8051ide.git
-#Vcs-Browser: http://git.debian.org/?p=collab-maint/mcu8051ide.git;a=summary
+Standards-Version: 3.9.4
+Homepage: http://mcu8051ide.sf.net
Package: mcu8051ide
Architecture: all
-Depends: ${misc:Depends}, bwidget (>= 1.8), itcl3 (>> 3.3), tcl8.5, tcllib, tk8.5, libtk-img, tdom (>= 0.8), tclx8.4
-Recommends: sdcc, doxygen
-Suggests: rxvt-unicode
-Description: Integrated development enviroment for MCS-51 based microcontrollers
- MCU 8051 IDE is a tool for developing programs in assembly or C languages
- (with SDCC) for microcontrollers based on industrial standard MCS-51.
- .
- It consist of editor with syntax highlight, auto completion, syntax validation
- and command line; compiler with support for macro-instructions (even
- macro in macro); simulator/debugger with small hardware simulation; scientific
- calculator, (rich) text editor for writing to do lists, hexadecimal editor and
- many other tools.
+Depends: ${misc:Depends}, bwidget (>= 1.8.0), itcl3, tdom (>= 0.8), tcllib (>= 1.10), tcl8.5, tk8.5, tclx8.4, libtk-img
+Suggests: rxvt-unicode, sdcc, doxygen, hunspell, make
+Description: Graphical Integrated Development Environment for 8051
+ MCU 8051 IDE is integrated development environment for microcontrollers based
+ on 8051. Supported programming languages are C and assembly. It has its own
+ assembler and support for 2 external assemblers. For C language it uses the
+ SDCC compiler.
diff --git a/debian/mcu8051ide.1 b/debian/mcu8051ide.1
index b010eea..4782038 100644
--- a/debian/mcu8051ide.1
+++ b/debian/mcu8051ide.1
@@ -1,5 +1,5 @@
.\"
-.\" MCU 8051 IDE - Itegrated development enviroment for MCS-51 based microcontrollers
+.\" MCU 8051 IDE - Itegrated development environment for MCS-51 based microcontrollers
.\" Copyright (C) 2007 Martin Osmera
.\"
.\" This program is free software; you can redistribute it and/or modify
@@ -16,12 +16,14 @@
.\" along with this program; if not, write to the Free Software
.\" Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
.\"
-.TH "MCU8051IDE" 1 "16 December 2007"
-.SH NAME MCU8051IDE \- Itegrated development enviroment for MCS-51 based microcontrollers
+.TH MCU8051IDE "1" "16 December 2007" "User Commands"
+.SH NAME MCU8051IDE \- Integrated development environment for MCS-51 based microcontrollers
.SH SYNOPSIS
.B mcu8051ide
.RB [ \-\-help ]
.RB [ \-h ]
+.RB [ \-\-assemble
+.IR asm_file ]
.RB [ \-\-compile
.IR asm_file ]
.RB [ \-\-iram\-size
@@ -134,8 +136,11 @@ Reformat indention in source code
\fB\-\-disassemble \fIinput\fR
Disaseble IHEX8 code and store result in input.asm
.TP
+\fB\-\-assemble \fIasm_file\fR
+Assemble the asm_file and exit program
+.TP
\fB\-\-compile \fIasm_file\fR
-Compile asm_file and exit program
+The same as \-\-assemble
.TP
\fB\-\-iram\-size \fIsize\fR
Set size of internal data memory (eg. 1K or 1024) (default: 0x100)
diff --git a/debian/mcu8051ide.install b/debian/mcu8051ide.install
index 402be1e..f3acbd3 100644
--- a/debian/mcu8051ide.install
+++ b/debian/mcu8051ide.install
@@ -5,6 +5,7 @@ icons/22x22/ usr/share/mcu8051ide/icons/
icons/32x32/ usr/share/mcu8051ide/icons/
icons/16x16/ usr/share/mcu8051ide/icons/
icons/mcu/ usr/share/mcu8051ide/icons/
+icons/flag/ usr/share/mcu8051ide/icons/
lib/ usr/share/mcu8051ide/
lib/pale/ usr/share/mcu8051ide/lib/
lib/utilities/ usr/share/mcu8051ide/lib/
@@ -14,12 +15,16 @@ lib/compiler/ usr/share/mcu8051ide/lib/
lib/simulator/ usr/share/mcu8051ide/lib/
lib/simulator/engine/ usr/share/mcu8051ide/lib/simulator/
lib/rightpanel/ usr/share/mcu8051ide/lib/
+lib/leftpanel/ usr/share/mcu8051ide/lib/
lib/bottompanel/ usr/share/mcu8051ide/lib/
-lib/dialogs/ usr/share/mcu8051ide/lib/
-lib/configdialogs/ usr/share/mcu8051ide/lib/
+lib/dialogues/ usr/share/mcu8051ide/lib/
+lib/configdialogues/ usr/share/mcu8051ide/lib/
demo/ usr/share/mcu8051ide/
+doc/handbook/ usr/share/mcu8051ide/doc/
+translations/ usr/share/mcu8051ide/
# Install execution wrappers
mcu8051ide usr/bin/
mcu8051ide.png usr/share/pixmaps/
mcu8051ide.desktop usr/share/applications/
+application-x-mcu8051ide.xml usr/share/mime/packages/
diff --git a/debian/patches/addlaunchscript.patch b/debian/patches/addlaunchscript.patch
new file mode 100644
index 0000000..19339ec
--- /dev/null
+++ b/debian/patches/addlaunchscript.patch
@@ -0,0 +1,9 @@
+Description: Added launch script
+Author: Fabricio Alcalde <f@lcald.com.ar>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- /dev/null
++++ b/mcu8051ide
+@@ -0,0 +1,2 @@
++#!/bin/sh
++exec tclsh8.5 /usr/share/mcu8051ide/lib/main.tcl "$@"
diff --git a/debian/patches/debian-changes-1.3.7-1 b/debian/patches/debian-changes-1.3.7-1
deleted file mode 100644
index ee6a045..0000000
--- a/debian/patches/debian-changes-1.3.7-1
+++ /dev/null
@@ -1,42 +0,0 @@
-Description: Upstream changes introduced in version 1.3.7-1
- This patch has been created by dpkg-source during the package build.
- Here's the last changelog entry, hopefully it gives details on why
- those changes were made:
- .
- mcu8051ide (1.3.7-1) unstable; urgency=low
- .
- * Initial release (Closes: #546549)
- * This is my first Debian package.
- .
- The person named in the Author field signed this changelog entry.
-Author: Fabricio Alcalde <f@lcald.com.ar>
-Bug-Debian: http://bugs.debian.org/546549
-
----
-The information above should follow the Patch Tagging Guidelines, please
-checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
-are templates for supplementary fields that you might want to add:
-
-Origin: <vendor|upstream|other>, <url of original patch>
-Bug: <url in upstream bugtracker>
-Bug-Debian: http://bugs.debian.org/<bugnumber>
-Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
-Forwarded: <no|not-needed|url proving that it has been forwarded>
-Reviewed-By: <name and email of someone who approved the patch>
-Last-Update: <YYYY-MM-DD>
-
---- /dev/null
-+++ mcu8051ide-1.3.7/mcu8051ide
-@@ -0,0 +1,2 @@
-+#!/bin/sh
-+exec tclsh8.5 /usr/share/mcu8051ide/lib/main.tcl "$@"
---- mcu8051ide-1.3.7.orig/mcu8051ide.desktop
-+++ mcu8051ide-1.3.7/mcu8051ide.desktop
-@@ -12,7 +12,6 @@ Name=MCU 8051 IDE
- Name[en_US]=MCU 8051 IDE
- StartupNotify=false
- Terminal=false
--TerminalOptions=
- TryExec=mcu8051ide
- Type=Application
- Version=1.0
diff --git a/debian/patches/fixdesktopfile.patch b/debian/patches/fixdesktopfile.patch
new file mode 100644
index 0000000..81f6797
--- /dev/null
+++ b/debian/patches/fixdesktopfile.patch
@@ -0,0 +1,23 @@
+Description: Removed deprecated options in .desktop file
+ Removed TerminalOptions and Encoding=UTF8.
+Author: Fabricio Alcalde <f@lcald.com.ar>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/mcu8051ide.desktop
++++ b/mcu8051ide.desktop
+@@ -2,7 +2,6 @@
+ Categories=Development;
+ Comment=Graphical IDE for MCS-51 based microcontrollers
+ Comment[en_US]=Graphical IDE for MCS-51 based microcontrollers
+-Encoding=UTF-8
+ Exec=mcu8051ide
+ GenericName=MCU 8051 IDE
+ GenericName[en_US]=MCU 8051 IDE
+@@ -12,7 +11,6 @@
+ Name[en_US]=MCU 8051 IDE
+ StartupNotify=false
+ Terminal=false
+-TerminalOptions=
+ TryExec=mcu8051ide
+ Type=Application
+ Version=1.0
diff --git a/debian/patches/series b/debian/patches/series
index d8c397d..c3f1811 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
-debian-changes-1.3.7-1
+fixdesktopfile.patch
+addlaunchscript.patch
diff --git a/debian/rules b/debian/rules
index ef5b18b..ae593ac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,9 @@ build-stamp:
dh_testdir
touch build-stamp
+build-arch: build
+build-indep: build
+
binary: binary-arch binary-indep
binary-arch: build
@@ -26,7 +29,7 @@ binary-indep: build
dh_prep
#Install files
- dh_install -Xlicence
+ dh_install --exclude=license.txt
dh_installdocs
dh_installmenu
dh_installman
diff --git a/debian/watch b/debian/watch
index b40eb34..8d74d48 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,23 +1,4 @@
-# Example watch control file for uscan
-# Rename this file to "watch" and then you can run the "uscan" command
-# to check for upstream updates and more.
-# See uscan(1) for format
-
# Compulsory line, this is a version 3 file
version=3
-# Uncomment to examine a Webpage
-# <Webpage URL> <string match>
-#http://www.example.com/downloads.php mcu8051ide-(.*)\.tar\.gz
-
-# Uncomment to examine a Webserver directory
-#http://www.example.com/pub/mcu8051ide-(.*)\.tar\.gz
-
-# Uncommment to examine a FTP server
-#ftp://ftp.example.com/pub/mcu8051ide-(.*)\.tar\.gz debian uupdate
-
-# Uncomment to find new files on sourceforge, for devscripts >= 2.9
- http://sf.net/mcu8051ide/mcu8051ide-(.*)\.tar\.gz
-
-# Uncomment to find new files on GooglePages
-# http://example.googlepages.com/foo.html mcu8051ide-(.*)\.tar\.gz
+http://sf.net/mcu8051ide/mcu8051ide-(.*)\.tar\.gz