summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README.source8
-rw-r--r--debian/changelog13
-rw-r--r--debian/compat1
-rw-r--r--debian/control17
-rw-r--r--debian/copyright25
-rw-r--r--debian/docs2
-rw-r--r--debian/mcu8051ide.1201
-rw-r--r--debian/mcu8051ide.install30
-rw-r--r--debian/mcu8051ide.manpages1
-rw-r--r--debian/menu2
-rw-r--r--debian/patches/addlaunchscript.patch9
-rw-r--r--debian/patches/fixdesktopfile.patch23
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules51
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch4
16 files changed, 390 insertions, 0 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..5191129
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,8 @@
+mcu8051ide for Debian
+---------------------
+
+CMAKE isn't used because nothing is compiled. Instead all files are copied
+with the dh_install script.
+
+
+
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..374c77f
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,13 @@
+mcu8051ide (1.4.7-1) unstable; urgency=low
+
+ * New upstream release.
+ * Fixed spelling error in the manpage.
+
+ -- Fabricio Alcalde <f@lcald.com.ar> Sat, 27 Apr 2013 15:40:07 +0000
+
+mcu8051ide (1.3.7-1) unstable; urgency=low
+
+ * Initial release (Closes: #546549)
+ * This is my first Debian package.
+
+ -- Fabricio Alcalde <f@lcald.com.ar> Sun, 04 Jul 2010 17:14:04 +0000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5c6bbd6
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,17 @@
+Source: mcu8051ide
+Section: electronics
+Priority: extra
+Maintainer: Fabricio Alcalde <f@lcald.com.ar>
+Build-Depends: debhelper (>= 7.0.50~)
+Standards-Version: 3.9.4
+Homepage: http://mcu8051ide.sf.net
+
+Package: mcu8051ide
+Architecture: all
+Depends: ${misc:Depends}, bwidget (>= 1.8.0), itcl3, tdom (>= 0.8), tcllib (>= 1.10), tcl8.5, tk8.5, tclx8.4, libtk-img
+Suggests: rxvt-unicode, sdcc, doxygen, hunspell, make
+Description: Graphical Integrated Development Environment for 8051
+ MCU 8051 IDE is integrated development environment for microcontrollers based
+ on 8051. Supported programming languages are C and assembly. It has its own
+ assembler and support for 2 external assemblers. For C language it uses the
+ SDCC compiler.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..c63c9cb
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,25 @@
+This work was packaged for Debian by:
+
+ Fabricio Alcalde <f@lcald.com.ar> on Sun, 04 Jul 2010 17:14:04 +0000
+
+It was downloaded from:
+
+ http://mcu8051ide.sf.net
+
+Upstream Author:
+
+ Martin Ošmera <martin.osmera@gmail.com>
+
+Copyright:
+
+ COPYRIGHT © 2007-2010 Martin Ošmera
+
+License:
+
+ This program is distributed under GNU GPL.
+ See `/usr/share/common-licenses/GPL-2'.
+
+The Debian packaging is:
+
+ Copyright (C) 2010 Fabricio Alcalde <f@lcald.com.ar> and is licensed under
+ the GPL, see "/usr/share/common-licenses/GPL-2".
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..724e084
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+README
+TODO
diff --git a/debian/mcu8051ide.1 b/debian/mcu8051ide.1
new file mode 100644
index 0000000..4782038
--- /dev/null
+++ b/debian/mcu8051ide.1
@@ -0,0 +1,201 @@
+.\"
+.\" MCU 8051 IDE - Itegrated development environment for MCS-51 based microcontrollers
+.\" Copyright (C) 2007 Martin Osmera
+.\"
+.\" This program is free software; you can redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as published by
+.\" the Free Software Foundation; either version 2 of the License, or
+.\" (at your option) any later version.
+.\"
+.\" This program is distributed in the hope that it will be useful,
+.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License
+.\" along with this program; if not, write to the Free Software
+.\" Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+.\"
+.TH MCU8051IDE "1" "16 December 2007" "User Commands"
+.SH NAME MCU8051IDE \- Integrated development environment for MCS-51 based microcontrollers
+.SH SYNOPSIS
+.B mcu8051ide
+.RB [ \-\-help ]
+.RB [ \-h ]
+.RB [ \-\-assemble
+.IR asm_file ]
+.RB [ \-\-compile
+.IR asm_file ]
+.RB [ \-\-iram\-size
+.IR size ]
+.RB [ \-\-code\-size
+.IR size ]
+.RB [ \-\-xram\-size
+.IR size ]
+.RB [ \-\-no\-opt ]
+.RB [ \-\-quiet ]
+.RB [ \-q ]
+.RB [ \-\-nosplash ]
+.RB [ \-\-nocolor ]
+.RB [ \-n ]
+.RB [ \-\-version ]
+.RB [ \-V ]
+.RB [ \-\-defaults ]
+.RB [ \-\-disassemble ]
+.RB [ \-\-minimalized ]
+.RB [ \-\-config\-file
+.IR filename ]
+.RB [ \-\-check\-libraries ]
+.RB [ \-\-ignore\-last\-session ]
+.RB [ \-\-open\-project
+.IR project ]
+.RB [ \-\-reset\-user\-settings ]
+.RB [ \-\-hex2bin
+.IR input
+.IR output ]
+.RB [ \-\-bin2hex
+.IR input
+.IR output ]
+.RB [ \-\-sim2hex
+.IR input
+.IR output ]
+.RB [ \-\-sim2bin
+.IR input
+.IR output ]
+.RB [ \-\-normalize\-hex
+.IR input ]
+.RB [ \-\-auto\-indent
+.IR input ]
+.RB [ \-\-comp\-quiet ]
+.RB [ \-\-no\-sim ]
+.RB [ \-\-no\-bin ]
+.RB [ \-\-no\-lst ]
+.RB [ \-\-no\-hex ]
+.RB [ \-\-warning\-level
+.IR N ]
+
+.SH DESCRIPTION
+\fB MCU 8051 IDE\fR is tool for developing programs in assembly language and C languge (with SDCC) for micronstollers based on industrial standard MCS-51. It consist of editor with syntax highlight, auto completion, syntax validation and command line, compiler with support for macro-instructions (even macro in macro), simulator, scientific calculator, (rich) text editor for writing to do lists, hexadecimal editor and many other tools.
+
+.SH OPTIONS
+.TP
+\fB\-\-help\fR, \fB\-h\fR
+Display short help text
+.TP
+\fB\-\-quiet\fR, \-q\fR
+Don't display status of initialization progress on startup
+.TP
+\fB\-\-nosplash\fR
+Don't show splash screen
+.TP
+\fB\-\-nocolor\fR, \-n\fR
+Disable color output
+.TP
+\fB\-\-version\fR, \fB\-V\fR
+Display version information
+.TP
+\fB\-\-defaults\fR
+Start with default settings (low level GUI settings (panel sizes ...))
+.TP
+\fB\-\-minimalized\fR
+Start with minimalized window
+.TP
+\fB\-\-config\-file \fIfilename\fR
+Specify path to file containg user settings
+.TP
+\fB\-\-check\-libraries\fR
+Check if all nessesary Tcl libraries are avaible
+.TP
+\fB\-\-ignore\-last\-session\fR
+Start with an empty session (no project will be opened at startup)
+.TP
+\fB\-\-open\-project \fIproject\fR
+Open only this project
+.TP
+\fB\-\-reset\-user\-settings\fR
+Reset all user settings to defaults
+.TP
+\fB\-\-hex2bin \fIinput output\fR
+Convert Intel Hex 8 file to binary file
+.TP
+\fB\-\-bin2hex \fIinput output\fR
+Convert binary file to Intel Hex 8 file
+.TP
+\fB\-\-sim2hex \fIinput output\fR
+Convert MCU 8051 IDE v0.9.1 simulator file to Intel Hex 8 file
+.TP
+\fB\-\-sim2bin \fIinput output\fR
+Convert MCU 8051 IDE v0.9.1 simulator file to binary file
+.TP
+\fB\-\-normalize\-hex \fIinput\fR
+Normalize IHEX8 file
+.TP
+\fB\-\-auto\-indent \fIinput\fR
+Reformat indention in source code
+.TP
+\fB\-\-disassemble \fIinput\fR
+Disaseble IHEX8 code and store result in input.asm
+.TP
+\fB\-\-assemble \fIasm_file\fR
+Assemble the asm_file and exit program
+.TP
+\fB\-\-compile \fIasm_file\fR
+The same as \-\-assemble
+.TP
+\fB\-\-iram\-size \fIsize\fR
+Set size of internal data memory (eg. 1K or 1024) (default: 0x100)
+.TP
+\fB\-\-code\-size \fIsize\fR
+Set size of program memory (eg. 1K or 1024) (default: 0x10000)
+.TP
+\fB\-\-xram\-size \fIsize\fR
+Set size of external data memory (eg. 1K or 1024) (default: 0x10000)
+.TP
+\fB\-\-no\-opt\fR
+Disable compiler optimalizations
+.TP
+\fB\-\-comp\-quiet\fR
+Suppress compiler console output
+.TP
+\fB\-\-no\-sim\fR
+Do not generate SIM file (for MCU 8051 IDE simulator)
+.TP
+\fB\-\-no\-bin\fR
+Do not generate binary object code
+.TP
+\fB\-\-no\-lst\fR
+Do not generate code listing
+.TP
+\fB\-\-no\-hex\fR
+.TP
+\fB\-\-warning\-level \fIN\fR
+Do not generate IHEX8 object code; 3 - Nothing; 2 - Errros only; 1 - Errors + Warnings; 0 - All (Default)
+
+.SH FILES
+.TP
+.I /usr/share/mcu8051ide/data/tips.conf
+XML file containing tips. (Dialog "Tip of the day")
+.TP
+.I /usr/share/mcu8051ide/data/mcus.conf
+XML definition of supported MCUs. \fBWarning: MCU 8051 IDE cannot run without this file.\fR Please do not rely on format of this file. It may be changed in future version without any warning.
+.TP
+.I ~/.mcu8051ide/last_session.conf
+INI like definition of the last session.
+.TP
+.I ~/.mcu8051ide/base.conf
+Base configuration file. It contains only three configuration keys separated by spaces, please do not rely on format of this file. It may be changed in future version without any warning.
+.TP
+.I ~/.mcu8051ide/config.conf
+Main configuration file (INI like). Readable and I hope user friendly.
+
+.SH NOTES
+List of supported porcessors is very short yet. Please post suggestions to martin.osmera@gmail.com .
+.SH SUPPORTED PROCESSORS
+8051, 80C51, 8052, AT89C2051, AT89C4051, AT89C51, AT89C51RC, AT89C52, AT89C55WD, AT89LV51, AT89LV52, AT89LV55, AT89S52, AT89LS51, AT89LS52, AT89S8253, AT89S2051, AT89S4051, AT89S52, AT89LS51, AT89LS52, AT89S8253, AT89S2051, AT89S4051, T87C5101, T83C5101, T83C5102, TS80C32X2, TS80C52X2, TS87C52X2, AT80C32X2, AT80C52X2, AT87C52X2, AT80C54X2, AT80C58X2, AT87C54X2, AT87C58X2, TS80C54X2, TS80C58X2, TS87C54X2, TS87C58X2, TS80C31X2, AT80C31X2
+
+.SH TO DO
+Add support for more MCS\-51 based microcontrollers.
+Fix all bugs.
+
+.SH AUTHOR
+Martin Osmera <martin.osmera@gmail.com>
diff --git a/debian/mcu8051ide.install b/debian/mcu8051ide.install
new file mode 100644
index 0000000..f3acbd3
--- /dev/null
+++ b/debian/mcu8051ide.install
@@ -0,0 +1,30 @@
+data/ usr/share/mcu8051ide/
+icons/ usr/share/mcu8051ide/
+icons/other/ usr/share/mcu8051ide/icons/
+icons/22x22/ usr/share/mcu8051ide/icons/
+icons/32x32/ usr/share/mcu8051ide/icons/
+icons/16x16/ usr/share/mcu8051ide/icons/
+icons/mcu/ usr/share/mcu8051ide/icons/
+icons/flag/ usr/share/mcu8051ide/icons/
+lib/ usr/share/mcu8051ide/
+lib/pale/ usr/share/mcu8051ide/lib/
+lib/utilities/ usr/share/mcu8051ide/lib/
+lib/editor/ usr/share/mcu8051ide/lib/
+lib/lib/ usr/share/mcu8051ide/lib/
+lib/compiler/ usr/share/mcu8051ide/lib/
+lib/simulator/ usr/share/mcu8051ide/lib/
+lib/simulator/engine/ usr/share/mcu8051ide/lib/simulator/
+lib/rightpanel/ usr/share/mcu8051ide/lib/
+lib/leftpanel/ usr/share/mcu8051ide/lib/
+lib/bottompanel/ usr/share/mcu8051ide/lib/
+lib/dialogues/ usr/share/mcu8051ide/lib/
+lib/configdialogues/ usr/share/mcu8051ide/lib/
+demo/ usr/share/mcu8051ide/
+doc/handbook/ usr/share/mcu8051ide/doc/
+translations/ usr/share/mcu8051ide/
+
+# Install execution wrappers
+mcu8051ide usr/bin/
+mcu8051ide.png usr/share/pixmaps/
+mcu8051ide.desktop usr/share/applications/
+application-x-mcu8051ide.xml usr/share/mime/packages/
diff --git a/debian/mcu8051ide.manpages b/debian/mcu8051ide.manpages
new file mode 100644
index 0000000..496692b
--- /dev/null
+++ b/debian/mcu8051ide.manpages
@@ -0,0 +1 @@
+debian/mcu8051ide.1
diff --git a/debian/menu b/debian/menu
new file mode 100644
index 0000000..20b71fc
--- /dev/null
+++ b/debian/menu
@@ -0,0 +1,2 @@
+?package(mcu8051ide):needs="X11" section="Applications/Programming"\
+ title="mcu8051ide" command="/usr/bin/mcu8051ide"
diff --git a/debian/patches/addlaunchscript.patch b/debian/patches/addlaunchscript.patch
new file mode 100644
index 0000000..19339ec
--- /dev/null
+++ b/debian/patches/addlaunchscript.patch
@@ -0,0 +1,9 @@
+Description: Added launch script
+Author: Fabricio Alcalde <f@lcald.com.ar>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- /dev/null
++++ b/mcu8051ide
+@@ -0,0 +1,2 @@
++#!/bin/sh
++exec tclsh8.5 /usr/share/mcu8051ide/lib/main.tcl "$@"
diff --git a/debian/patches/fixdesktopfile.patch b/debian/patches/fixdesktopfile.patch
new file mode 100644
index 0000000..81f6797
--- /dev/null
+++ b/debian/patches/fixdesktopfile.patch
@@ -0,0 +1,23 @@
+Description: Removed deprecated options in .desktop file
+ Removed TerminalOptions and Encoding=UTF8.
+Author: Fabricio Alcalde <f@lcald.com.ar>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/mcu8051ide.desktop
++++ b/mcu8051ide.desktop
+@@ -2,7 +2,6 @@
+ Categories=Development;
+ Comment=Graphical IDE for MCS-51 based microcontrollers
+ Comment[en_US]=Graphical IDE for MCS-51 based microcontrollers
+-Encoding=UTF-8
+ Exec=mcu8051ide
+ GenericName=MCU 8051 IDE
+ GenericName[en_US]=MCU 8051 IDE
+@@ -12,7 +11,6 @@
+ Name[en_US]=MCU 8051 IDE
+ StartupNotify=false
+ Terminal=false
+-TerminalOptions=
+ TryExec=mcu8051ide
+ Type=Application
+ Version=1.0
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..c3f1811
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+fixdesktopfile.patch
+addlaunchscript.patch
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ae593ac
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,51 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ #Nothing to do
+ dh_testdir
+ touch build-stamp
+
+build-arch: build
+build-indep: build
+
+binary: binary-arch binary-indep
+
+binary-arch: build
+ #Nothing to do
+
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_prep
+
+ #Install files
+ dh_install --exclude=license.txt
+ dh_installdocs
+ dh_installmenu
+ dh_installman
+ dh_installchangelogs
+ dh_link
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+.PHONY: build clean binary-indep binary-arch binary
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..8d74d48
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+# Compulsory line, this is a version 3 file
+version=3
+
+http://sf.net/mcu8051ide/mcu8051ide-(.*)\.tar\.gz