summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeilBrown <neilb@suse.de>2010-09-03 13:33:29 +1000
committerNeilBrown <neilb@suse.de>2010-09-03 13:33:29 +1000
commit8efb9d16ac4026ca237a2d887240543b1763b634 (patch)
tree9ce6decdf97dafba5d7e35463786bb7dbdbd6218
parent972ee7253a4f55a0f3e0e5ab89e02ed333481234 (diff)
Fix compile error on non-x86 systems.
-z is not an option for 'gcc', it is an option for the loader!! Reported-by: Debian build system Signed-off-by: NeilBrown <neilb@suse.de>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e2c65a5d..0cc9a87c 100644
--- a/Makefile
+++ b/Makefile
@@ -167,7 +167,7 @@ mdmon.O2 : $(MON_SRCS) mdadm.h mdmon.h
# use '-z now' to guarantee no dynamic linker interactions with the monitor thread
mdmon : $(MON_OBJS)
- $(CC) $(LDFLAGS) $(MON_LDFLAGS) -z now -o mdmon $(MON_OBJS) $(LDLIBS)
+ $(CC) $(LDFLAGS) $(MON_LDFLAGS) -Wl,-z,now -o mdmon $(MON_OBJS) $(LDLIBS)
msg.o: msg.c msg.h
test_stripe : restripe.c mdadm.h