summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormadduck <madduck@3cfab66f-1918-0410-86b3-c06b76f9a464>2006-08-01 13:17:51 +0000
committermadduck <madduck@3cfab66f-1918-0410-86b3-c06b76f9a464>2006-08-01 13:17:51 +0000
commit3ee67c7d890a0bb9980632ca16c8ccb749167cb0 (patch)
tree1dbfea92048f2ceb4895bfa877ec9b7611412ab0
parentda620fa0530435d639959e7cc57e6af70b08a5a4 (diff)
* Applied patch by upstream to fix the logic of the --run switch (see
#287415). Thus also reverted the mdadm-raid hack used to fix the bug in the 2.5.2-9 upload.
-rw-r--r--debian/changelog5
-rw-r--r--debian/mdadm-raid2
-rwxr-xr-xdebian/patches/99-run-logic-FIX.dpatch53
3 files changed, 58 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index d867a372..062cb30d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,11 @@
mdadm (2.5.2-10) UNRELEASED; urgency=low
* Added README.checkarray with some information about the check process.
+ * Applied patch by upstream to fix the logic of the --run switch (see
+ #287415). Thus also reverted the mdadm-raid hack used to fix the bug in
+ the 2.5.2-9 upload.
- -- martin f. krafft <madduck@debian.org> Tue, 1 Aug 2006 12:11:18 +0100
+ -- martin f. krafft <madduck@debian.org> Tue, 1 Aug 2006 14:16:55 +0100
mdadm (2.5.2-9) unstable; urgency=low
diff --git a/debian/mdadm-raid b/debian/mdadm-raid
index b26abdc9..649b9faa 100644
--- a/debian/mdadm-raid
+++ b/debian/mdadm-raid
@@ -80,7 +80,7 @@ case "${1:-}" in
IFSOLD=${IFS:-}
IFS='
'
- for line in $($MDADM --assemble --scan --run --auto=yes 2>&1); do
+ for line in $($MDADM --assemble --scan --auto=yes 2>&1); do
IFS=$IFSOLD
set -- $line
shift
diff --git a/debian/patches/99-run-logic-FIX.dpatch b/debian/patches/99-run-logic-FIX.dpatch
new file mode 100755
index 00000000..3afd32d7
--- /dev/null
+++ b/debian/patches/99-run-logic-FIX.dpatch
@@ -0,0 +1,53 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 99-run-logic-FIX.dpatch by martin f. krafft <madduck@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad mdadm-2.5.2.obsolete.0.0575067182808233~/mdadm.c mdadm-2.5.2.obsolete.0.0575067182808233/mdadm.c
+--- mdadm-2.5.2.obsolete.0.0575067182808233~/mdadm.c 2006-06-26 06:11:00.000000000 +0100
++++ mdadm-2.5.2.obsolete.0.0575067182808233/mdadm.c 2006-08-01 14:16:07.253413451 +0100
+@@ -1017,7 +1017,7 @@
+ else {
+ rv |= Assemble(ss, array_list->devname, mdfd,
+ array_list,
+- devlist, NULL,
++ NULL, NULL,
+ readonly, runstop, NULL, homehost, verbose-quiet, force);
+ if (rv == 0) cnt++;
+ }
+@@ -1036,7 +1036,7 @@
+ do {
+ rv2 = Assemble(ss, NULL, -1,
+ &ident,
+- devlist, NULL,
++ NULL, NULL,
+ readonly, runstop, NULL, homehost, verbose-quiet, force);
+ if (rv2==0) {
+ cnt++;
+@@ -1049,7 +1049,6 @@
+ auto_update_home = 0;
+ } while (rv2!=2);
+ /* Incase there are stacked devices, we need to go around again */
+- devlist = conf_get_devs();
+ } while (acnt);
+ if (cnt == 0 && auto_update_home && homehost) {
+ /* Nothing found, maybe we need to bootstrap homehost info */
+@@ -1058,7 +1057,7 @@
+ do {
+ rv2 = Assemble(ss, NULL, -1,
+ &ident,
+- devlist, NULL,
++ NULL, NULL,
+ readonly, runstop, "homehost", homehost, verbose-quiet, force);
+ if (rv2==0) {
+ cnt++;
+@@ -1066,7 +1065,6 @@
+ }
+ } while (rv2!=2);
+ /* Incase there are stacked devices, we need to go around again */
+- devlist = conf_get_devs();
+ } while (acnt);
+ }
+ if (cnt == 0 && rv == 0) {