summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormartin f. krafft <madduck@debian.org>2010-09-05 08:04:29 +0200
committermartin f. krafft <madduck@debian.org>2010-09-05 08:04:44 +0200
commit0b80e69a2a980be27d30536099b69e76688ba7cc (patch)
tree1966f4adefe3a04e9f0ebeb0b45bed75131c55ae
parent1e484e02b5c31afb1cd19f12ded5f49a0ccff794 (diff)
do not print io rescheduling info message when run by cron
Signed-off-by: martin f. krafft <madduck@debian.org>
-rw-r--r--debian/changelog1
-rw-r--r--debian/checkarray4
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index dfc278f2..5b696c48 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
mdadm (3.1.5-1~unreleased.0) UNRELEASED; urgency=low
* Bump Standards-Version to 3.9.1; no changes required.
+ * Do not print io rescheduling info message when run by cron.
-- martin f. krafft <madduck@debian.org> Fri, 03 Sep 2010 11:53:37 +0200
diff --git a/debian/checkarray b/debian/checkarray
index bd15ad5f..dafc6529 100644
--- a/debian/checkarray
+++ b/debian/checkarray
@@ -193,7 +193,9 @@ for array in $arrays; do
wait=$((wait - 1))
resync_pid=$(ps -ef | awk -v dev=$array 'BEGIN { pattern = "^\\[" dev "_resync]$" } $8 ~ pattern { print $2 }')
if [ -n "$resync_pid" ]; then
- echo "$PROGNAME: I: selecting $ionice I/O scheduling class for resync of $array." >&2
+ if [ $cron != 1 ]; then
+ echo "$PROGNAME: I: selecting $ionice I/O scheduling class for resync of $array." >&2
+ fi
ionice -p "$resync_pid" $arg
break
fi