summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormadduck <madduck@3cfab66f-1918-0410-86b3-c06b76f9a464>2006-11-11 19:14:36 +0000
committermadduck <madduck@3cfab66f-1918-0410-86b3-c06b76f9a464>2006-11-11 19:14:36 +0000
commit0a80972f381e22a6450ac7364d2847f8a54daa9c (patch)
tree8e0177e20873fd88cb30ac1128cea9695ae436c4
parent86b61328c5611df88d0646f46fdd8a9d1f359ae0 (diff)
* Actually remove mdadm.conf on purge; previously, the generation of
a temporary file for initramfs would screw up the purging; thanks to Fabrice Lorrain for the report (closes: #398088).
-rw-r--r--debian/changelog8
-rw-r--r--debian/initramfs/hook2
-rw-r--r--debian/mdadm.postrm2
-rw-r--r--debian/startall2
4 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 01771644..62a13754 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mdadm (2.5.6-4) unstable; urgency=low
+
+ * Actually remove mdadm.conf on purge; previously, the generation of
+ a temporary file for initramfs would screw up the purging; thanks to
+ Fabrice Lorrain for the report (closes: #398088).
+
+ -- martin f. krafft <madduck@debian.org> Sat, 11 Nov 2006 20:07:55 +0100
+
mdadm (2.5.6-3) unstable; urgency=low
* Fix a syntax error in mdadm-raid script.
diff --git a/debian/initramfs/hook b/debian/initramfs/hook
index 497151ab..e921880b 100644
--- a/debian/initramfs/hook
+++ b/debian/initramfs/hook
@@ -150,7 +150,7 @@ else
if [ $use_temp -eq 1 ]; then
tmpfile="${DESTMDADMCONF}.tmp"
- if /usr/share/mdadm/mkconf generate $tmpfile; then
+ if /usr/share/mdadm/mkconf > $tmpfile; then
# all is well, we now have a temporary configuration file
info "auto-generated temporary mdadm.conf configuration file." >&2
install_config $tmpfile $DESTMDADMCONF
diff --git a/debian/mdadm.postrm b/debian/mdadm.postrm
index fc5a06fa..25342f85 100644
--- a/debian/mdadm.postrm
+++ b/debian/mdadm.postrm
@@ -18,11 +18,11 @@ case "${1:-}" in
;;
purge)
- rm -f /etc/default/mdadm
GEN_SENTINEL=/var/lib/mdadm/mdadm.conf-generated
if [ -r $GEN_SENTINEL ]; then
rm -f "$(sed -rne 's,[[:xdigit:]]+ ,,p' $GEN_SENTINEL)"
fi
+ rm -f /etc/default/mdadm /etc/mdadm.conf /etc/mdadm/mdadm.conf
rm -rf /var/lib/mdadm
;;
diff --git a/debian/startall b/debian/startall
index 907c883b..00fd039f 100644
--- a/debian/startall
+++ b/debian/startall
@@ -17,7 +17,7 @@ ALTCONFIG=/etc/mdadm.conf
modprobe -kq md 2>/dev/null || :
if [ ! -f $CONFIG ] && [ ! -f $ALTCONFIG ]; then
- /usr/share/mdadm/mkconf generate $CONFIG || ret=$?
+ /usr/share/mdadm/mkconf > $CONFIG || ret=$?
case ${ret:-0} in
0) :;;
255) echo W: mdadm: using existing mdadm.conf file... >&2;;