summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Tokarev <mjt@tls.msk.ru>2014-10-04 20:05:20 +0400
committerMichael Tokarev <mjt@tls.msk.ru>2014-10-04 20:32:00 +0400
commit61c54b388ce54b8129d039aa6d422aaca0dd0e77 (patch)
treec7e3f309f7a09de300211149d96db7747e30539a
parentfbb57805a9f4464bded172510269000f1794201f (diff)
install systemd services
-rw-r--r--debian/changelog2
-rw-r--r--debian/mdadm-waitidle1
-rw-r--r--debian/mdadm.init1
-rw-r--r--debian/mdadm.postinst2
-rw-r--r--debian/mdadm.postrm2
-rwxr-xr-xdebian/rules4
6 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 93ebd150..375752bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ mdadm (3.3.2-2) UNRELEASED; urgency=medium
* removed AUTOSTART variable from /etc/default/mdadm
(system will start arrays listed in mdadm.conf)
* simplify d/rules, build udeb in a subdir (for now, to be removed)
+ * install systemd services and disable some initscripts (mask them)
+ when systemd is running (Closes: #763959)
-- Michael Tokarev <mjt@tls.msk.ru> Sat, 04 Oct 2014 15:43:57 +0400
diff --git a/debian/mdadm-waitidle b/debian/mdadm-waitidle
index e779d7ba..920272c7 100644
--- a/debian/mdadm-waitidle
+++ b/debian/mdadm-waitidle
@@ -1,4 +1,5 @@
#!/bin/sh
+# This script is not used when systemd is running
### BEGIN INIT INFO
# Provides: mdadm-waitidle
# Required-Start:
diff --git a/debian/mdadm.init b/debian/mdadm.init
index d8855f61..8b603796 100644
--- a/debian/mdadm.init
+++ b/debian/mdadm.init
@@ -1,6 +1,7 @@
#!/bin/sh
#
# Start the MD monitor daemon for all active MD arrays if desired.
+# This script is not used under systemd.
#
# Copyright © 2001-2005 Mario Jou/3en <joussen@debian.org>
# Copyright © 2005-2009 Martin F. Krafft <madduck@debian.org>
diff --git a/debian/mdadm.postinst b/debian/mdadm.postinst
index b05dca30..9ef03306 100644
--- a/debian/mdadm.postinst
+++ b/debian/mdadm.postinst
@@ -106,6 +106,8 @@ _eof
;;
esac
+[ -d /run/systemd/system ] && systemctl --system daemon-reload >/dev/null || :
+
# See #369953
set +u
#DEBHELPER#
diff --git a/debian/mdadm.postrm b/debian/mdadm.postrm
index 80591a76..ea6a0baa 100644
--- a/debian/mdadm.postrm
+++ b/debian/mdadm.postrm
@@ -16,6 +16,8 @@ case "${1:-}" in
esac
+[ -d /run/systemd/system ] && systemctl --system daemon-reload >/dev/null || :
+
# just in case somebody actually purges mdadm, we need this to make debconf
# (added by dh_installdebconf) behave. See #369953
set +u
diff --git a/debian/rules b/debian/rules
index 3a7921c3..bd4b6a55 100755
--- a/debian/rules
+++ b/debian/rules
@@ -48,7 +48,7 @@ install-arch: build-arch
dh_clean -k
dh_installdirs
- $(MAKE) install DESTDIR=$(DESTDIR)
+ $(MAKE) install install-systemd DESTDIR=$(DESTDIR)
install -Dm0755 debian/initramfs/hook \
$(DESTDIR)/usr/share/initramfs-tools/hooks/mdadm
@@ -74,7 +74,9 @@ binary-arch: install-arch
dh_installexamples -pmdadm mdadm.conf-example misc/syslog-events
dh_installinit --init-script=mdadm-raid --no-restart-on-upgrade -- start 25 S . start 60 0 6 .
dh_installinit --init-script=mdadm-waitidle --no-start -- stop 98 0 6 .
+ dh_link -pmdadm /dev/null /lib/systemd/system/mdadm-waitidle.service
dh_installinit -- defaults 25
+ dh_link -pmdadm /dev/null /lib/systemd/system/mdadm.service
dh_installman
dh_installcron
dh_installchangelogs ChangeLog