summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeilBrown <neilb@suse.de>2014-06-05 16:45:56 +1000
committerNeilBrown <neilb@suse.de>2014-06-05 16:54:24 +1000
commit9275a5ec5962cad9798fbae13ad645766af03e90 (patch)
tree2259ce123d194b4ba2de7430b1f43fde35e685cf
parent1e60caebbcebd3375b8bc5dc2ef244983620e4d0 (diff)
Release mdadm-3.3.1
Signed-off-by: NeilBrown <neilb@suse.de>
-rw-r--r--ANNOUNCE-3.3.123
-rw-r--r--ReadMe.c6
-rwxr-xr-xinventory15
-rw-r--r--mdadm.8.in2
-rw-r--r--mdadm.spec2
-rw-r--r--mdassemble.82
-rw-r--r--mdmon.82
7 files changed, 45 insertions, 7 deletions
diff --git a/ANNOUNCE-3.3.1 b/ANNOUNCE-3.3.1
new file mode 100644
index 00000000..7d5e666e
--- /dev/null
+++ b/ANNOUNCE-3.3.1
@@ -0,0 +1,23 @@
+Subject: ANNOUNCE: mdadm 3.3.1 - A tool for managing md Soft RAID under Linux
+
+I am pleased to announce the availability of
+ mdadm version 3.3.1
+
+It is available at the usual places:
+ http://www.kernel.org/pub/linux/utils/raid/mdadm/
+and via git at
+ git://github.com/neilbrown/mdadm
+ git://neil.brown.name/mdadm
+ http://git.neil.brown.name/git/mdadm.git
+
+The main changes are:
+ - lots of work on "DDF" support. Hopefully it will be more stable
+ now. Bug reports are always welcome.
+ - improved interactions with 'systemd'. Where possible, background
+ tasks are run from systemd (if it is present) rather then forking
+ disassociationg from the session. This is important because udev
+ doesn't really let you disassociate.
+
+though there are a number of other little bug fixes too.
+
+NeilBrown 5th June 2014
diff --git a/ReadMe.c b/ReadMe.c
index bd8c85e4..02cea081 100644
--- a/ReadMe.c
+++ b/ReadMe.c
@@ -1,7 +1,7 @@
/*
* mdadm - manage Linux "md" devices aka RAID arrays.
*
- * Copyright (C) 2001-2013 Neil Brown <neilb@suse.de>
+ * Copyright (C) 2001-2014 Neil Brown <neilb@suse.de>
*
*
* This program is free software; you can redistribute it and/or modify
@@ -25,10 +25,10 @@
#include "mdadm.h"
#ifndef VERSION
-#define VERSION "3.3"
+#define VERSION "3.3.1"
#endif
#ifndef VERS_DATE
-#define VERS_DATE "3rd September 2013"
+#define VERS_DATE "5th June 2014"
#endif
char Version[] = Name " - v" VERSION " - " VERS_DATE "\n";
diff --git a/inventory b/inventory
index 7aff3743..d7f22aeb 100755
--- a/inventory
+++ b/inventory
@@ -18,6 +18,7 @@ ANNOUNCE-3.2.4
ANNOUNCE-3.2.5
ANNOUNCE-3.2.6
ANNOUNCE-3.3
+ANNOUNCE-3.3.1
Assemble.c
Build.c
COPYING
@@ -75,6 +76,7 @@ mdmon.h
mdopen.c
mdstat.c
misc/
+misc/mdcheck
misc/syslog-events
mkinitramfs
monitor.c
@@ -103,7 +105,13 @@ super1.c
swap_super.c
sysfs.c
systemd/
+systemd/SUSE-mdadm_env.sh
+systemd/mdadm-grow-continue@.service
+systemd/mdadm-last-resort@.service
+systemd/mdadm-last-resort@.timer
+systemd/mdadm.shutdown
systemd/mdmon@.service
+systemd/mdmonitor.service
test
tests/
tests/00linear
@@ -128,6 +136,7 @@ tests/02r6grow
tests/03assem-incr
tests/03r0assem
tests/03r5assem
+tests/03r5assem-failed
tests/03r5assemV1
tests/04r0update
tests/04r1update
@@ -173,13 +182,19 @@ tests/07testreshape5
tests/09imsm-assemble
tests/09imsm-create-fail-rebuild
tests/09imsm-overlap
+tests/10ddf-assemble-missing
tests/10ddf-create
tests/10ddf-create-fail-rebuild
tests/10ddf-fail-create-race
+tests/10ddf-fail-readd
+tests/10ddf-fail-readd-readonly
tests/10ddf-fail-spare
+tests/10ddf-fail-stop-readd
tests/10ddf-fail-twice
tests/10ddf-fail-two-spares
tests/10ddf-geometry
+tests/10ddf-incremental-wrong-order
+tests/10ddf-sudden-degraded
tests/11spare-migration
tests/12imsm-r0_2d-grow-r0_3d
tests/12imsm-r0_2d-grow-r0_4d
diff --git a/mdadm.8.in b/mdadm.8.in
index 718bcdba..a85c3d0a 100644
--- a/mdadm.8.in
+++ b/mdadm.8.in
@@ -5,7 +5,7 @@
.\" the Free Software Foundation; either version 2 of the License, or
.\" (at your option) any later version.
.\" See file COPYING in distribution for details.
-.TH MDADM 8 "" v3.3
+.TH MDADM 8 "" v3.3.1
.SH NAME
mdadm \- manage MD devices
.I aka
diff --git a/mdadm.spec b/mdadm.spec
index 8e6e1062..d09ea7b9 100644
--- a/mdadm.spec
+++ b/mdadm.spec
@@ -1,6 +1,6 @@
Summary: mdadm is used for controlling Linux md devices (aka RAID arrays)
Name: mdadm
-Version: 3.3
+Version: 3.3.1
Release: 1
Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.gz
URL: http://neil.brown.name/blog/mdadm
diff --git a/mdassemble.8 b/mdassemble.8
index 1ec83f5b..889675c5 100644
--- a/mdassemble.8
+++ b/mdassemble.8
@@ -1,5 +1,5 @@
.\" -*- nroff -*-
-.TH MDASSEMBLE 8 "" v3.3
+.TH MDASSEMBLE 8 "" v3.3.1
.SH NAME
mdassemble \- assemble MD devices
.I aka
diff --git a/mdmon.8 b/mdmon.8
index d7d26205..9bdf760d 100644
--- a/mdmon.8
+++ b/mdmon.8
@@ -1,5 +1,5 @@
.\" See file COPYING in distribution for details.
-.TH MDMON 8 "" v3.3
+.TH MDMON 8 "" v3.3.1
.SH NAME
mdmon \- monitor MD external metadata arrays