summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormartin f. krafft <madduck@debian.org>2018-05-15 12:10:33 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2018-05-15 12:10:33 +0100
commit3e6ba10f8aa782e354742d7ac978dd9c5722f9cb (patch)
tree5d2587fd32da48cf0e7b38497deb7b373bf17666
parentbb29ccb7241e6871fa4ef008d45b7c0dade873bc (diff)
Remove -Werror from compiler flags
-Werror seems like a bad idea on released/packaged code because a toolchain update (introducing new warnings) could break the build. We'll let upstream use it to beautify the code, but remove it for out builds. Signed-off-by: martin f. krafft <madduck@debian.org> Gbp-Pq: Name debian-no-Werror.diff
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index cb5759ba..8d349d14 100644
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,7 @@ KLIBC_GCC = gcc -nostdinc -iwithprefix include -I$(KLIBC)/klibc/include -I$(KLIB
CC ?= $(CROSS_COMPILE)gcc
CXFLAGS ?= -ggdb
-CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
+CWFLAGS = -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter
ifdef WARN_UNUSED
CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O3
endif