summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNeilBrown <neilb@suse.de>2010-07-28 17:04:42 +1000
committerNeilBrown <neilb@suse.de>2010-07-28 17:41:35 +1000
commit7f5de63d511c24629231ed5712525d460688e0f8 (patch)
tree4d005bdcc2d3bfc5feb3420f50d3dc5844c72485 /Makefile
parent08415c46a867b26743b6b4fc93d5fc6ed027cb07 (diff)
Switch from /lib/init/rw to /dev for early-boot files.
It turns out that /lib/init/rw doesn't exist in early boot like I thought. So give up on that idea and just use /dev/.mdadm/ for files that must persist from early-boot to regular boot. Signed-off-by: NeilBrown <neilb@suse.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 5dd0e404..818e2d1b 100644
--- a/Makefile
+++ b/Makefile
@@ -66,11 +66,11 @@ MAILCMD =/usr/sbin/sendmail -t
CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)\" -DCONFFILE2=\"$(CONFFILE2)\"
# Both MAP_DIR and MDMON_DIR should be somewhere that persists across the
# pivotroot from early boot to late boot.
-# If you don't have /lib/init/rw you might want to use /dev/.something
-# e.g. make MAP_DIR=/dev/.mdadm
-MAP_DIR = /lib/init/rw/mdadm
+# /dev is an odd place to put this, but it is the only directory that
+# meets the requirements.
+MAP_DIR=/dev/.mdadm
MAP_FILE = map
-MDMON_DIR = /lib/init/rw/mdmon
+MDMON_DIR = /dev/.mdadm
DIRFLAGS = -DMAP_DIR=\"$(MAP_DIR)\" -DMAP_FILE=\"$(MAP_FILE)\"
DIRFLAGS += -DMDMON_DIR=\"$(MDMON_DIR)\"
CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS) $(DIRFLAGS)