summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-11 14:54:42 +1000
committerNeilBrown <neilb@suse.de>2011-04-11 14:54:42 +1000
commit8ccca44dde83e91a162373c681d3ad3bf9023c0e (patch)
tree5f530021cb028f72a06eb83341e4d25f79177df1 /Makefile
parentb1bac75b265f2dd07273ea0f6ee7e633fce8ecfc (diff)
mdadm/mdmon: use CFLAGS when linking
People often put flags that control ABI options into CFLAGS (like -mcpu) and don't duplicate them in LDFLAGS because most build systems nowadays (like autotools) use both when linking. So make that work with mdadm's custom build system too. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: NeilBrown <neilb@suse.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 222358f2..72087bea 100644
--- a/Makefile
+++ b/Makefile
@@ -149,10 +149,10 @@ everything-test: all mdadm.static swap_super test_stripe \
# mdadm.tcc doesn't work..
mdadm : $(OBJS)
- $(CC) $(LDFLAGS) -o mdadm $(OBJS) $(LDLIBS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o mdadm $(OBJS) $(LDLIBS)
mdadm.static : $(OBJS) $(STATICOBJS)
- $(CC) $(LDFLAGS) -static -o mdadm.static $(OBJS) $(STATICOBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -static -o mdadm.static $(OBJS) $(STATICOBJS)
mdadm.tcc : $(SRCS) $(INCL)
$(TCC) -o mdadm.tcc $(SRCS)
@@ -172,7 +172,7 @@ mdmon.O2 : $(MON_SRCS) $(INCL) mdmon.h
# use '-z now' to guarantee no dynamic linker interactions with the monitor thread
mdmon : $(MON_OBJS)
- $(CC) $(LDFLAGS) $(MON_LDFLAGS) -Wl,-z,now -o mdmon $(MON_OBJS) $(LDLIBS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(MON_LDFLAGS) -Wl,-z,now -o mdmon $(MON_OBJS) $(LDLIBS)
msg.o: msg.c msg.h
test_stripe : restripe.c mdadm.h