summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPiergiorgio Sartor <piergiorgio.sartor@nexgo.de>2011-04-05 08:56:41 +1000
committerNeilBrown <neilb@suse.de>2011-04-05 08:56:41 +1000
commita9c2c6c697d2d3d01e1b6d1930ca971abceed5f7 (patch)
treed921fd2086bc9abc887d13088efe5e191b026bfd /Makefile
parent78c0a3b17fcf6972bfcd10f02a5f4520117281d0 (diff)
RAID-6 check standalone md device
Allow RAID-6 check to be passed only the MD device, start and length. The three parameters are mandatory. All necessary information is collected using the "sysfs_read()" call. Furthermore, if "length" is "0", then the check is performed until the end of the array. Some checks are done, for example if the md device is really a RAID-6. Nevertheless I guess it is not bullet proof... Next patch will include the "suspend" action. My idea is to do it "per stripe", please let me know if you've some better options. Signed-off-by: NeilBrown <neilb@suse.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 6bdaed95..7c656e30 100644
--- a/Makefile
+++ b/Makefile
@@ -107,7 +107,7 @@ OBJS = mdadm.o config.o policy.o mdstat.o ReadMe.o util.o maps.o lib.o \
restripe.o sysfs.o sha1.o mapfile.o crc32.o sg_io.o msg.o \
platform-intel.o probe_roms.o
-OBJSX = restripe.o
+CHECK_OBJS = restripe.o sysfs.o maps.o lib.o
SRCS = $(patsubst %.o,%.c,$(OBJS))
@@ -177,8 +177,8 @@ msg.o: msg.c msg.h
test_stripe : restripe.c mdadm.h
$(CC) $(CXFLAGS) $(LDFLAGS) -o test_stripe -DMAIN restripe.c
-raid6check : raid6check.o mdadm.h $(OBJSX)
- $(CC) $(CXFLAGS) $(LDFLAGS) -o raid6check raid6check.o $(OBJSX)
+raid6check : raid6check.o mdadm.h $(CHECK_OBJS)
+ $(CC) $(CXFLAGS) $(LDFLAGS) -o raid6check raid6check.o $(CHECK_OBJS)
mdassemble : $(ASSEMBLE_SRCS) $(INCL)
rm -f $(OBJS)