summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-12 15:24:15 -0400
committerNeilBrown <neilb@suse.de>2012-08-13 08:07:49 +1000
commitbb624f78b9203416d2d35bb69148d7dce2bcf55a (patch)
tree5ed090e7cf400ac291f8eceb715e7fb54887f806 /Makefile
parent7ec0996cf65bbaffc4fa72560c12f118318d6367 (diff)
fix handling of CPPFLAGS
The current Makefile ends up ignoring the system CPPFLAGS settings, so make sure we append the variable. Also, the old metadata logic has a typo with the flag name. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: NeilBrown <neilb@suse.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 315455ba..704b3747 100644
--- a/Makefile
+++ b/Makefile
@@ -48,12 +48,10 @@ CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O
endif
ifdef DEBIAN
-CPPFLAGS := -DDEBIAN
-else
-CPPFLAGS :=
+CPPFLAGS += -DDEBIAN
endif
ifdef DEFAULT_OLD_METADATA
- CPPFLAG += -DDEFAULT_OLD_METADATA
+ CPPFLAGS += -DDEFAULT_OLD_METADATA
DEFAULT_METADATA=0.90
else
DEFAULT_METADATA=1.2