summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichael Tokarev <mjt@tls.msk.ru>2013-09-17 20:20:40 +0400
committerNeilBrown <neilb@suse.de>2013-09-18 09:21:23 +1000
commitfe8ea9407f0fbc5ffb8d2a37ba4618a2112b9a65 (patch)
tree55927775a062edd10dcb4fa5b097fccfa1846808 /Makefile
parent9eaf410feda4ad112d3cee0c0b5b4edf05fc63bf (diff)
Remove bashism from Makefile
Makefile uses [ x == y ] construct which does not work with POSIX shell. Since this is just testing a flag, replace it with string comparison (=) operator instead. Signed-off-By: Michael Tokarev <mjt@tls.msk.ru> Signed-off-by: NeilBrown <neilb@suse.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e8da3a5d..c60cc2cf 100644
--- a/Makefile
+++ b/Makefile
@@ -156,7 +156,7 @@ all : check_rundir mdadm mdmon
man : mdadm.man md.man mdadm.conf.man mdmon.man raid6check.man
check_rundir:
- @if [ ! -d "$(dir $(RUN_DIR))" -a "$(CHECK_RUN_DIR)" == 1 ]; then \
+ @if [ ! -d "$(dir $(RUN_DIR))" -a "$(CHECK_RUN_DIR)" = 1 ]; then \
echo "***** Parent of $(RUN_DIR) does not exist. Maybe set different RUN_DIR="; \
echo "***** e.g. make RUN_DIR=/dev/.mdadm" ; \
echo "***** or set CHECK_RUN_DIR=0"; exit 1; \