summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNeilBrown <neilb@suse.de>2010-08-05 13:13:02 +1000
committerNeilBrown <neilb@suse.de>2010-08-05 13:13:02 +1000
commitf21e18ca8969f21549c646096f354eac57cd53a8 (patch)
tree5e0b0474075ba8f629860964914fe18a6892ccd4 /Makefile
parent9aaada0530396078063b17d138beb74fcbcfeebc (diff)
Compile with -Wextra by default
This produced lots of warning, some of which pointed to actual bugs. Signed-off-by: NeilBrown <neilb@suse.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 818e2d1b..4b20cd86 100644
--- a/Makefile
+++ b/Makefile
@@ -42,7 +42,7 @@ KLIBC_GCC = gcc -nostdinc -iwithprefix include -I$(KLIBC)/klibc/include -I$(KLIB
CC = $(CROSS_COMPILE)gcc
CXFLAGS = -ggdb
-CWFLAGS = -Wall -Werror -Wstrict-prototypes
+CWFLAGS = -Wall -Werror -Wstrict-prototypes -Wextra -Wno-unused-parameter
ifdef WARN_UNUSED
CWFLAGS += -Wp,-D_FORTIFY_SOURCE=2 -O
endif