summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2016-07-28 15:51:35 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2016-07-28 16:52:46 +0100
commitca114f3c76374493f0fd64f8ea0a9b96ae9b1dc5 (patch)
treebc9868009a6ce0bafa9a4737938e1684e2d15e40 /debian/rules
parent22821d8e740c4012566c4bc672acdb8f545cf89f (diff)
Bring in changes from Ubuntu, to bring packages in sync.debian/3.4-4
* Bring in changes from Ubuntu, to make the two packages in sync: - Drop README.Debian, quite out-of-date w.r.t. current packaging. - debian/control - on ubuntu, downgrade default-mta from Recommends to Suggests. - update-grub in postinst, if available (note does not update grub1). - drop stderr warnings in postrm. - drop presubj, out of date, and all types of bugs are welcomed. - on ubuntu, install apport package hook. - on ubuntu, install incremental assembly udev rules into udeb.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 9 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 3a1b5a6f..1ed970a9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -64,11 +64,13 @@ install-arch: build-arch
install -Dm0755 debian/mkconf $(DESTDIR)/usr/share/mdadm/mkconf
install -Dm0755 debian/checkarray $(DESTDIR)/usr/share/mdadm/checkarray
install -Dm0755 debian/bugscript $(DESTDIR)/usr/share/bug/mdadm/script
- install -Dm0644 debian/presubj $(DESTDIR)/usr/share/bug/mdadm/presubj
-
install -Dm0755 udeb/mdadm $(DESTDIR_UDEB)/sbin/mdadm
install -Dm0755 udeb/mdmon $(DESTDIR_UDEB)/sbin/mdmon
install -Dm0644 udev-md-raid-arrays.rules $(DESTDIR_UDEB)/lib/udev/rules.d/63-md-raid-arrays.rules
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes), yes)
+ install -Dm0644 udev-md-raid-assembly.rules $(DESTDIR_UDEB)/lib/udev/rules.d/64-md-raid-assembly.rules
+ install -Dm0644 debian/source_mdadm.py $(DESTDIR)/usr/share/apport/package-hooks/source_mdadm.py
+endif
binary-arch: install-arch
dh_testdir
@@ -90,7 +92,11 @@ binary-arch: install-arch
dh_fixperms
dh_installdeb
dh_shlibdeps
- dh_gencontrol
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes), yes)
+ dh_gencontrol -- -Vmta:Suggests="default-mta | mail-transport-agent"
+else
+ dh_gencontrol -- -Vmta:Recommends="default-mta | mail-transport-agent"
+endif
dh_md5sums
dh_builddeb