summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2016-07-02 19:16:01 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2016-07-02 19:16:01 +0100
commitb83f8fcaffa542498c5698a3a161b9967ac1d3d6 (patch)
tree3cb83259723d112fd7b08b5bd299df2f5ee94009 /debian/rules
mdadm (3.4-2) unstable; urgency=low
* Reneable incremental assembly * Rely on udev to assemble incremental arrays * In environments with systemd rely on mdadm-last-resort@.timer|.service units to activate degrated raids * In environments initramfs-tools initrd (no systemd) add local-block script to do the same after 2/3rds of root delay iteration * Drop local-top initramfs script * Drop dependency on initscripts package * Drop INITRDSTART support * Drop mdadm-raid init script * Drop ancient preinst * In mdadm.init remove dependency on mdadm-raid * In mdadm.init check, and bail out running in a container * In mdadm.config drop mdadm/autostart logic * Drop CREATE stanzas from mkconf and don't include them in the initramfs. The generated defaults, are the compiled-in defaults. And the current one generates warnings when running mdadm in the initramfs, as there is no passwd|group files to resolve root/disk uid/gid. Closes: 717609 * Adapt changes and formatting of initramfs hook from Ubuntu * Bump standards version to 3.9.7, no changes required * Fix copyright-refers-to-symlink-license * Closes: #781172, #796624, #769201, #813335, #632401, #804973, #714155, #770002, #737132, #675452, #726390, #813637, #814036. # imported from the archive
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules103
1 files changed, 103 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..3a1b5a6f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,103 @@
+#!/usr/bin/make -f
+# Copyright © 2001-2005 Mario Jou/3en <joussen@debian.org>
+# Copyright © 2005-2008 Martin F. Krafft <madduck@debian.org>
+# Distributable under the terms of the GNU GPL version 2.
+#
+
+#export DH_VERBOSE=1
+
+export CROSS_COMPILE=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)-
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
+CXFLAGS = $(shell dpkg-buildflags --get CFLAGS) \
+ $(shell dpkg-buildflags --get CPPFLAGS)
+BUILDFLAGS = CXFLAGS="$(CXFLAGS)" LDFLAGS="$(LDFLAGS)" DEBIAN=yes
+DESTDIR = $(CURDIR)/debian/mdadm
+DESTDIR_UDEB = $(DESTDIR)-udeb
+
+build-arch: build-stamp
+
+build-stamp:
+ dh_testdir
+ $(MAKE) all $(BUILDFLAGS) CONFFILE=/etc/mdadm/mdadm.conf CONFFILE2=/etc/mdadm.conf
+ touch $@
+
+# udeb rules should go, the only diff is the conffile location,
+# and d-i specifies path explicitly when needed
+
+udeb/dir-stamp:
+ rm -rf udeb
+ mkdir udeb
+ ln *.[ch] Makefile udeb/
+ touch $@
+
+build-arch: udeb/build-stamp
+
+udeb/build-stamp: udeb/dir-stamp
+ dh_testdir
+ $(MAKE) -C udeb mdadm mdmon $(BUILDFLAGS) CONFFILE=/tmp/mdadm.conf
+ touch $@
+
+clean:
+ dh_testdir
+ rm -f build-stamp
+ $(MAKE) clean
+ rm -rf udeb
+ dh_clean
+
+install-arch: build-arch
+ dh_testdir
+ dh_prep
+ dh_installdirs
+
+ $(MAKE) install install-systemd DESTDIR=$(DESTDIR)
+
+ mkdir -p $(DESTDIR)/etc/mdadm
+ install -Dm0755 debian/initramfs/hook \
+ $(DESTDIR)/usr/share/initramfs-tools/hooks/mdadm
+ install -Dm0755 debian/initramfs/script.local-block \
+ $(DESTDIR)/usr/share/initramfs-tools/scripts/local-block/mdadm
+ install -Dm0755 debian/initramfs/script.local-bottom \
+ $(DESTDIR)/usr/share/initramfs-tools/scripts/local-bottom/mdadm
+ install -Dm0644 debian/mdadm.modules \
+ $(DESTDIR)/etc/modprobe.d/mdadm.conf
+
+ install -Dm0755 debian/mkconf $(DESTDIR)/usr/share/mdadm/mkconf
+ install -Dm0755 debian/checkarray $(DESTDIR)/usr/share/mdadm/checkarray
+ install -Dm0755 debian/bugscript $(DESTDIR)/usr/share/bug/mdadm/script
+ install -Dm0644 debian/presubj $(DESTDIR)/usr/share/bug/mdadm/presubj
+
+ install -Dm0755 udeb/mdadm $(DESTDIR_UDEB)/sbin/mdadm
+ install -Dm0755 udeb/mdmon $(DESTDIR_UDEB)/sbin/mdmon
+ install -Dm0644 udev-md-raid-arrays.rules $(DESTDIR_UDEB)/lib/udev/rules.d/63-md-raid-arrays.rules
+
+binary-arch: install-arch
+ dh_testdir
+ dh_testroot
+ dh_installdebconf
+ dh_installdocs
+ dh_installexamples -pmdadm mdadm.conf-example misc/syslog-events
+ dh_installinit --init-script=mdadm-waitidle --no-start -- stop 98 0 6 .
+ dh_link -pmdadm /dev/null /lib/systemd/system/mdadm-waitidle.service
+ dh_installinit -- defaults 25
+ dh_link -pmdadm /dev/null /lib/systemd/system/mdadm.service
+ dh_installman
+ dh_installcron
+ dh_installchangelogs ChangeLog
+ dh_installlogcheck
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+build: build-arch
+install: install-arch
+binary: binary-arch
+build-indep:
+install-indep:
+binary-indep:
+.PHONY: clean build build-indep build-arch binary binary-indep binary-arch install install-indep install-arch