summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Tokarev <mjt@tls.msk.ru>2014-10-04 21:28:16 +0400
committerMichael Tokarev <mjt@tls.msk.ru>2014-10-04 21:28:54 +0400
commit1d5b3d94ab1590a5e7b526828fddee75de86514b (patch)
tree0e0e195719953a18a0fc76c42e8e4c85a205fa42 /debian
parent767a70677f345df54b966c00ba45a9418430cd8b (diff)
build-sys-no-check_rundir.patch: do not relink executables at install time
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/build-sys-no-check_rundir.patch33
-rw-r--r--debian/patches/series1
3 files changed, 36 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 375752bb..ab7d5a77 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,8 @@ mdadm (3.3.2-2) UNRELEASED; urgency=medium
* simplify d/rules, build udeb in a subdir (for now, to be removed)
* install systemd services and disable some initscripts (mask them)
when systemd is running (Closes: #763959)
+ * build-sys-no-check_rundir.patch: stop (re)linking executables
+ at install time
-- Michael Tokarev <mjt@tls.msk.ru> Sat, 04 Oct 2014 15:43:57 +0400
diff --git a/debian/patches/build-sys-no-check_rundir.patch b/debian/patches/build-sys-no-check_rundir.patch
new file mode 100644
index 00000000..61f3a6f0
--- /dev/null
+++ b/debian/patches/build-sys-no-check_rundir.patch
@@ -0,0 +1,33 @@
+Subject: build-sys: do not depend on check_rundir for executables
+From: Michael Tokarev <mjt@tls.msk.ru>
+To: linux-raid@vger.kernel.org
+
+The problem is that the link lines will always be executed
+even if the executables are up to date.
+
+If anything, this check_rundir should be a dependency of
+install target, or some other "phony" target like this,
+since check_rundir is phony by itself.
+
+Signed-off-by: Michael Tokarev <mjt@tls.msk.ru>
+
+--- a/Makefile
++++ b/Makefile
+@@ -172,7 +172,7 @@ everything-test: all mdadm.static swap_super test_stripe \
+ # mdadm.uclibc and mdassemble.uclibc don't work on x86-64
+ # mdadm.tcc doesn't work..
+
+-mdadm : check_rundir $(OBJS)
++mdadm : $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o mdadm $(OBJS) $(LDLIBS)
+
+ mdadm.static : $(OBJS) $(STATICOBJS)
+@@ -195,7 +195,7 @@ mdmon.O2 : $(MON_SRCS) $(INCL) mdmon.h
+ $(CC) -o mdmon.O2 $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(MON_LDFLAGS) -DHAVE_STDINT_H -O2 -D_FORTIFY_SOURCE=2 $(MON_SRCS)
+
+ # use '-z now' to guarantee no dynamic linker interactions with the monitor thread
+-mdmon : check_rundir $(MON_OBJS)
++mdmon : $(MON_OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(MON_LDFLAGS) -Wl,-z,now -o mdmon $(MON_OBJS) $(LDLIBS)
+ msg.o: msg.c msg.h
+
diff --git a/debian/patches/series b/debian/patches/series
index 117751e7..956eedd8 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@ debian-conffile-location.diff
debian-no-Werror.diff
sha1-includes.diff
use-external-blkid.diff
+build-sys-no-check_rundir.patch