summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMichael Tokarev <mjt@tls.msk.ru>2014-09-20 09:09:24 +0400
committerMichael Tokarev <mjt@tls.msk.ru>2014-09-20 09:09:55 +0400
commitb0c161ab4a878e5c639823908cf2b224b56c1904 (patch)
treec75ead16155442407022d68120cbac14012deece /debian
parent39fe2cf0649b014a470f7d0d363867a863d31857 (diff)
denote md init errors in initramfs from fatal to warning (#733574)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/initramfs/script.local-top8
2 files changed, 6 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 363aeb68..5328a5fa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ mdadm (3.3.2-1) UNRELEASED; urgency=low
* removed remove-bashism-from-makefile.patch (applied upstream)
* copy 64-md-raid-assembly.rules to initramfs too, this should
bring us array auto-assemble during initramfs run (Closes: #678691)
+ * denote inability to initialize md subsystem in local-top script
+ from fatal error to warning (Closes: #733574)
-- Michael Tokarev <mjt@tls.msk.ru> Sat, 20 Sep 2014 08:49:59 +0400
diff --git a/debian/initramfs/script.local-top b/debian/initramfs/script.local-top
index 166f256f..b95ad896 100644
--- a/debian/initramfs/script.local-top
+++ b/debian/initramfs/script.local-top
@@ -17,7 +17,7 @@ maybe_break pre-mdadm
if [ -e /scripts/local-top/md ]; then
log_warning_msg "old md initialisation script found, getting out of its way..."
- exit 1
+ exit 0
fi
MDADM=/sbin/mdadm
@@ -42,11 +42,11 @@ if [ "$MD_DEVS" = none ]; then
fi
if [ ! -f /proc/mdstat ] && ! modprobe -q md_mod; then
- verbose && log_failure_msg "failed to load module md_mod."
+ verbose && log_warning_msg "failed to load module md_mod."
fi
if [ ! -f /proc/mdstat ]; then
- verbose && panic "cannot initialise MD subsystem (/proc/mdstat missing)"
- exit 1
+ verbose && log_warning_msg "cannot initialise MD subsystem (/proc/mdstat missing)"
+ exit 0
fi
# prevent writes/syncs so that resuming works (#415441).