summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/mdadm.postinst31
-rwxr-xr-xdebian/rules2
3 files changed, 30 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index ae7fdfba..9a2e286f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-mdadm (2.5.3-1~unreleased.1) UNRELEASED; urgency=low
+mdadm (2.5.3-1~unreleased.2) UNRELEASED; urgency=low
* New upstream release.
- now the --run switch behaves as stated in the manpage. This properly
@@ -8,6 +8,9 @@ mdadm (2.5.3-1~unreleased.1) UNRELEASED; urgency=low
a bug and hope upstream will use dX (e.g. d0) instead in a future
version.
* Now rebuilds initramfs for all installed kernels.
+ * Removed udev rules because it was causing unbootable systems when the
+ kernel autoassembly assembled the RAIDs (and not mdadm) and thus no device
+ nodes were created.
-- martin f. krafft <madduck@debian.org> Mon, 7 Aug 2006 11:39:01 +0100
diff --git a/debian/mdadm.postinst b/debian/mdadm.postinst
index 4b2fb7de..e205a8bb 100644
--- a/debian/mdadm.postinst
+++ b/debian/mdadm.postinst
@@ -127,6 +127,23 @@ then
update-rc.d -f mdadm-raid remove
fi
+# try to undo udev rules (installed by 2.5.2-10, see 2.5.3-1 changelog)
+# commented original install snippet included below
+if [ "${1:-}" = "configure" ] && [ "${2:-}" = "2.5.2-10" ]; then
+ # first, disable the rules
+ rm -f /etc/udev/rules.d/z60_mdadm.rules
+
+ if echo "0843432c9c01ed95c42481eee0cf6fbf /etc/udev/mdadm.rules" \
+ | md5sum -c >/dev/null; then
+ # no changes by user, so remove
+ rm -f /etc/udev/mdadm.rules
+ else
+ echo "W: I tried to remove /etc/udev/mdadm.rules (see changelog), but you" >&2
+ echo "W: have modified it, so I won't touch it. Please remove the file" >&2
+ echo "W: at your leisure." >&2
+ fi
+fi
+
# See #369953
set +u
#DEBHELPER#
@@ -142,12 +159,14 @@ if [ -x /etc/init.d/mdadm-raid ]; then
fi
fi
+#see 2.5.3-1 changelog why this is commented out.
# install udev symlink if it's not already there and we're being upgraded,
# see #359614
-V=2.5.2-10
-F=/etc/udev/rules.d/z60_mdadm.rules
-if [ "${1:-}" = "configure" ] && dpkg --compare-versions "${2:-$V}" lt $V \
- && [ ! -e $F ]; then
+#V=2.5.2-10
+#F=/etc/udev/rules.d/z60_mdadm.rules
+#if [ "${1:-}" = "configure" ] && dpkg --compare-versions "${2:-$V}" lt $V \
+# && [ ! -e $F ]; then
+#
+# ln -s ../mdadm.rules $F
+#fi
- ln -s ../mdadm.rules $F
-fi
diff --git a/debian/rules b/debian/rules
index 593244b5..487c7f76 100755
--- a/debian/rules
+++ b/debian/rules
@@ -101,7 +101,7 @@ binary-arch: build install
dh_installcron
dh_installchangelogs ChangeLog
dh_installlogcheck
- dh_installudev
+ #dh_installudev
dh_strip
dh_compress
dh_fixperms