summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--debian/mdadm-raid1
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 34add4a2..2ed64fe9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,8 +13,10 @@ mdadm (3.1.5-1~unreleased.0) UNRELEASED; urgency=low
* Schedule start/stop of mdadm-raid before/after filesystems are
checked&mounted/unmounted; thanks to Mario 'BitKoenig' Holbe
(closes: #611632).
+ * Work around a shell coding bug for cases when there are zero active
+ devices (closes: #618561).
- -- martin f. krafft <madduck@debian.org> Mon, 31 Jan 2011 16:25:40 +0100
+ -- martin f. krafft <madduck@debian.org> Sun, 20 Mar 2011 07:37:46 +0100
mdadm (3.1.4-1+8efb9d1) unstable; urgency=low
diff --git a/debian/mdadm-raid b/debian/mdadm-raid
index 91ef5f5f..e85ec095 100644
--- a/debian/mdadm-raid
+++ b/debian/mdadm-raid
@@ -174,6 +174,7 @@ case "${1:-}" in
log_action_begin_msg "Generating udev events for MD arrays"
for uevent in /sys/block/md*/uevent; do
+ test -e $uevent || break
sentinel=${uevent#/sys/block/}; sentinel=${sentinel%/uevent}-uevent
test -e ${STATEDIR:-/doesnotexist}/$sentinel && continue
test -w $uevent || continue