summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile8
-rw-r--r--mdadm.h6
-rw-r--r--mdmon.82
3 files changed, 8 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 5dd0e404..818e2d1b 100644
--- a/Makefile
+++ b/Makefile
@@ -66,11 +66,11 @@ MAILCMD =/usr/sbin/sendmail -t
CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)\" -DCONFFILE2=\"$(CONFFILE2)\"
# Both MAP_DIR and MDMON_DIR should be somewhere that persists across the
# pivotroot from early boot to late boot.
-# If you don't have /lib/init/rw you might want to use /dev/.something
-# e.g. make MAP_DIR=/dev/.mdadm
-MAP_DIR = /lib/init/rw/mdadm
+# /dev is an odd place to put this, but it is the only directory that
+# meets the requirements.
+MAP_DIR=/dev/.mdadm
MAP_FILE = map
-MDMON_DIR = /lib/init/rw/mdmon
+MDMON_DIR = /dev/.mdadm
DIRFLAGS = -DMAP_DIR=\"$(MAP_DIR)\" -DMAP_FILE=\"$(MAP_FILE)\"
DIRFLAGS += -DMDMON_DIR=\"$(MDMON_DIR)\"
CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS) $(DIRFLAGS)
diff --git a/mdadm.h b/mdadm.h
index b95c9c9a..54df02a1 100644
--- a/mdadm.h
+++ b/mdadm.h
@@ -70,10 +70,10 @@ extern __off64_t lseek64 __P ((int __fd, __off64_t __offset, int __whence));
/* MAP_DIR should be somewhere that persists across the pivotroot
* from early boot to late boot.
- * If you don't have /lib/init/rw you might want to use /dev/.something
+ * Currently /dev seems to be the only option on most distros.
*/
#ifndef MAP_DIR
-#define MAP_DIR "/lib/init/rw/mdadm"
+#define MAP_DIR "/dev/.mdadm"
#endif /* MAP_DIR */
/* MAP_FILE is what we name the map file we put in MAP_DIR, in case you
* want something other than the default of "map"
@@ -90,7 +90,7 @@ extern __off64_t lseek64 __P ((int __fd, __off64_t __offset, int __whence));
* boot process and stays up as long as possible during shutdown.
*/
#ifndef MDMON_DIR
-#define MDMON_DIR "/lib/init/rw/mdmon"
+#define MDMON_DIR "/dev/.mdadm/"
#endif /* MDMON_DIR */
#include "md_u.h"
diff --git a/mdmon.8 b/mdmon.8
index 53dd5d2c..0c24732f 100644
--- a/mdmon.8
+++ b/mdmon.8
@@ -208,7 +208,7 @@ and
.B .sock
file on. The particular filesystem to use is given to mdmon at compile
time and defaults to
-.BR /lib/init/rw .
+.BR /dev/.mdadm .
This filesystem must persist through to the end of the boot sequence.