summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control2
-rw-r--r--debian/patches/Makefile4
-rwxr-xr-xdebian/rules20
3 files changed, 5 insertions, 21 deletions
diff --git a/debian/control b/debian/control
index 1358a63b..2b25082f 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: admin
Priority: optional
Maintainer: Debian mdadm maintainers <pkg-mdadm-devel@lists.alioth.debian.org>
Uploaders: martin f. krafft <madduck@debian.org>, Mario Joussen <joussen@debian.org>
-Build-Depends: debhelper (>= 5), po-debconf, dpatch, groff-base, docbook-to-man
+Build-Depends: debhelper (>= 5), po-debconf, groff-base, docbook-to-man
Standards-Version: 3.7.2
XS-Vcs-Git: git://git.debian.org/git/pkg-mdadm/mdadm
diff --git a/debian/patches/Makefile b/debian/patches/Makefile
deleted file mode 100644
index af67986f..00000000
--- a/debian/patches/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-.PHONY: 00list
-00list:
- find -maxdepth 1 -type f -name \*.dpatch -print \
- | sed -re 's,^\./(.*)\.dpatch$$,\1,' | sort -n > $@
diff --git a/debian/rules b/debian/rules
index 6936fde1..f5de6703 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,26 +14,17 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CXFLAGS += -O0
CXFLAGS_UDEB += -O0
else
- CXFLAGS += -O2
+ CXFLAGS += -O2
CXFLAGS_UDEB += -Os
endif
-include /usr/share/dpatch/dpatch.make
-
-$(DPATCH_STAMPFN): debian/patches/00list
-force-run:
-.PHONY: force-run
-debian/patches/00list: force-run
- dh_testdir
- make -sC debian/patches
-
.PHONY: configure
-configure: debian/patches/00list
+configure:
debian/mdadm-startall.8: debian/mdadm-startall.sgml
docbook-to-man $< > $@
-build: configure patch build-stamp
+build: configure build-stamp
build-stamp: debian/mdadm-startall.8
dh_testdir
$(MAKE) -f debian/rules mdadm.udeb DEBIAN=yes
@@ -54,10 +45,7 @@ mdadm: configure
$(MAKE) $(FLAGS) all
.PHONY: mdadm
-clean: clean-patched unpatch
- rm -f debian/patches/00list
-
-clean-patched:
+clean:
dh_testdir
dh_testroot
rm -f build-stamp