summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/TODO2
-rw-r--r--debian/changelog6
-rw-r--r--debian/mdadm.init2
-rw-r--r--debian/mdadm.postinst6
4 files changed, 14 insertions, 2 deletions
diff --git a/debian/TODO b/debian/TODO
index 34833468..2401f93d 100644
--- a/debian/TODO
+++ b/debian/TODO
@@ -26,4 +26,6 @@ debian mdadm TODO list
- also only stop those array we started; this can be easily done with
sentinels in $STATEDIR
+- manage DAEMON_OPTIONS with debconf
+
$Id$
diff --git a/debian/changelog b/debian/changelog
index 22585a04..abbde1ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,12 @@ mdadm (2.5.6-7) unstable; urgency=low
(closes: #402106).
* Prevent modules from being loaded during initramfs time if no arrays are
to be assembled at this stage.
+ * Export DAEMON_OPTIONS to /etc/default/mdadm, which gets passed to the
+ mdadm daemon on startup from the init.d script. The value is set to
+ --syslog by default, and will get incorporated into debconf in a future
+ version.
- -- martin f. krafft <madduck@debian.org> Fri, 8 Dec 2006 12:14:07 +0400
+ -- martin f. krafft <madduck@debian.org> Fri, 8 Dec 2006 12:31:36 +0400
mdadm (2.5.6-6) unstable; urgency=medium
diff --git a/debian/mdadm.init b/debian/mdadm.init
index 29939cf8..570b10f3 100644
--- a/debian/mdadm.init
+++ b/debian/mdadm.init
@@ -52,7 +52,7 @@ case "${1:-}" in
mkdir -p $RUNDIR
set +e
start-stop-daemon -S -p $PIDFILE -x $MDADM -- \
- --monitor --pid-file $PIDFILE --daemonise --scan
+ --monitor --pid-file $PIDFILE --daemonise --scan ${DAEMON_OPTIONS:-}
log_end_msg $?
set -e
fi
diff --git a/debian/mdadm.postinst b/debian/mdadm.postinst
index 65a96ee7..ebaf07dd 100644
--- a/debian/mdadm.postinst
+++ b/debian/mdadm.postinst
@@ -85,6 +85,8 @@ case "${1:-}" in
AUTOCHECK="${RET:-true}"
db_get mdadm/start_daemon
START_DAEMON="${RET:-true}"
+ #db_get mdadm/daemon_options
+ [ -n "$DAEMON_OPTIONS" ] || DAEMON_OPTIONS='--syslog'
cat <<_eof > $DEBIANCONFIG
# mdadm Debian configuration
@@ -115,6 +117,10 @@ AUTOCHECK=$AUTOCHECK
# should mdadm start the MD monitoring daemon during boot?
START_DAEMON=$START_DAEMON
+# DAEMON_OPTIONS:
+# additional options to pass to the daemon.
+DAEMON_OPTIONS="$DAEMON_OPTIONS"
+
# VERBOSE=
# if this variable is set to true, mdadm will be a little more verbose e.g.
# when creating the initramfs.