summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/mdadm.config13
2 files changed, 20 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 675a5114..f88cf21a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+mdadm (2.5.3.git200608202239-5~unreleased.3) UNRELEASED; urgency=low
+
+ * Added stripped implementation of debconf-escape to .config file to cater
+ for upgrades from systems with older debconf versions.
+
+ -- martin f. krafft <madduck@debian.org> Sat, 16 Sep 2006 13:01:26 +0200
+
mdadm (2.5.3.git200608202239-5~unreleased.2) UNRELEASED; urgency=medium
* Modified the patch responsible for pruning parent devices so that
diff --git a/debian/mdadm.config b/debian/mdadm.config
index 9fdde4dc..1376e578 100644
--- a/debian/mdadm.config
+++ b/debian/mdadm.config
@@ -79,6 +79,19 @@ get_initrdstart() {
db_capb escape
+if [ ! -x "$(command -v debconf-escape)" ]; then
+ debconf-escape()
+ { # copied from debconf 1.4.72:
+ perl -e '
+ while (<>) {
+ s/\\/\\\\/g;
+ s/\n/\\n/g;
+ print;
+ }
+ '
+ }
+fi
+
msg=intro; suffix=''; error=0
while true; do
db_metaget mdadm/initrdstart_msg_${msg} extended_description || :