summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/debian-run-udev.diff37
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules7
4 files changed, 10 insertions, 43 deletions
diff --git a/debian/changelog b/debian/changelog
index c3da9e18..2e1a9865 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mdadm (3.2.4-1) UNRELEASED; urgency=low
+
+ * new upstream (bugfix) release (Closes: #664088, #661552)
+ * removed debian-run-udev.diff (applied upstream), and
+ all RUNDIR handling from debian/rules (it is the default now)
+
+ -- Michael Tokarev <mjt@tls.msk.ru> Thu, 10 May 2012 17:51:41 +0400
+
mdadm (3.2.3-3) unstable; urgency=low
* switch from topgit to plain 3.0 (quilt) layout, creating
diff --git a/debian/patches/debian-run-udev.diff b/debian/patches/debian-run-udev.diff
deleted file mode 100644
index 5d85a1aa..00000000
--- a/debian/patches/debian-run-udev.diff
+++ /dev/null
@@ -1,37 +0,0 @@
-From: Roger Leigh <rleigh@codelibre.net>
-Subject: check for /run/udev in addition to /dev/.udev
-
-On Debian (and probably other distros too), /dev/.udev
-has been moved /run/udev, and mdadm checks if udev is
-running by verifying its directory. So check /run/udev
-too.
-
-Forwarded: not-needed
-Reviewed-by: Michael Tokarev <mjt@tls.msk.ru>
-
-diff -urN mdadm-3.2.2.orig/Manage.c mdadm-3.2.2/Manage.c
---- mdadm-3.2.2.orig/Manage.c 2011-06-14 03:50:01.000000000 +0100
-+++ mdadm-3.2.2/Manage.c 2012-01-18 10:47:13.086097662 +0000
-@@ -333,7 +333,8 @@
-
-
- if (devnum != NoMdDev &&
-- (stat("/dev/.udev", &stb) != 0 ||
-+ (stat("/run/udev", &stb) != 0 ||
-+ stat("/dev/.udev", &stb) != 0 ||
- check_env("MDADM_NO_UDEV"))) {
- struct map_ent *mp = map_by_devnum(&map, devnum);
- remove_devices(devnum, mp ? mp->path : NULL);
-diff -urN mdadm-3.2.2.orig/mdopen.c mdadm-3.2.2/mdopen.c
---- mdadm-3.2.2.orig/mdopen.c 2011-04-24 13:23:10.000000000 +0100
-+++ mdadm-3.2.2/mdopen.c 2012-01-18 10:47:36.242413633 +0000
-@@ -318,7 +318,8 @@
- * If we cannot detect udev, we need to make
- * devices and links ourselves.
- */
-- if (stat("/dev/.udev", &stb) != 0 ||
-+ if (stat("/run/udev", &stb) != 0 ||
-+ stat("/dev/.udev", &stb) != 0 ||
- check_env("MDADM_NO_UDEV")) {
- /* Make sure 'devname' exists and 'chosen' is a symlink to it */
- if (lstat(devname, &stb) == 0) {
diff --git a/debian/patches/series b/debian/patches/series
index 9921517c..fc8d5536 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
debian-conffile-location.diff
debian-disable-udev-incr-assembly.diff
debian-no-Werror.diff
-debian-run-udev.diff
diff --git a/debian/rules b/debian/rules
index 0be77e78..d3402bc3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,9 +6,6 @@
#export DH_VERBOSE=1
-RUNDIR = /run/mdadm
-RUNOPTS = MAP_DIR=$(RUNDIR) MDMON_DIR=$(RUNDIR) FAILED_SLOTS_DIR=$(RUNDIR)/failed-slots
-
CXFLAGS = -ggdb
CXFLAGS_UDEB := $(CXFLAGS) -fomit-frame-pointer
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -36,14 +33,14 @@ build-stamp: debian/mdadm-startall.8
mdadm.udeb: FLAGS = CXFLAGS="$(CXFLAGS_UDEB)" CONFFILE=/tmp/mdadm.conf
mdadm.udeb: configure
dh_testdir
- $(MAKE) $(FLAGS) all $(RUNOPTS)
+ $(MAKE) $(FLAGS) all
mv mdadm mdadm.udeb
.PHONY: mdadm.udeb
mdadm: FLAGS = CXFLAGS="$(CXFLAGS)" CONFFILE=/etc/mdadm/mdadm.conf CONFFILE2=/etc/mdadm.conf
mdadm: configure
dh_testdir
- $(MAKE) $(FLAGS) all $(RUNOPTS)
+ $(MAKE) $(FLAGS) all
.PHONY: mdadm
INTERPOLATED_FILES = debian/bugscript debian/mkconf