summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--debian/initramfs/hook4
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index c8f8a40f..32aa9749 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,10 @@ mdadm (3.3.4-1) unstable; urgency=medium
[ Helmut Grohne ]
* Fix FTCBFS. Export CROSS_COMPILE=<triplet>- (Closes: #794335)
+ [ Cyril B. ]
+ * Copy AUTO lines from host into initrd, when updating initrd.
+ (Closes: #785104)
+
-- Dimitri John Ledkov <xnox@debian.org> Sun, 08 Nov 2015 11:48:03 +0000
mdadm (3.3.2-5) unstable; urgency=medium
diff --git a/debian/initramfs/hook b/debian/initramfs/hook
index 85bad65e..74ed7e38 100644
--- a/debian/initramfs/hook
+++ b/debian/initramfs/hook
@@ -90,9 +90,9 @@ install_config()
{
# install the configuration file
mkdir -p ${2%/*}
- # only copy ARRAY/DEVICE/HOMEHOST lines, and merge continuation lines into one
+ # only copy ARRAY/DEVICE/HOMEHOST/AUTO lines, and merge continuation lines into one
if [ -f "$1" ] ; then
- sed -e :a -re '$!N;s/\n[[:space:]]+/ /;ta' -ne '/^(ARRAY|DEVICE|HOMEHOST)/P;D' $1 > $2
+ sed -e :a -re '$!N;s/\n[[:space:]]+/ /;ta' -ne '/^(ARRAY|DEVICE|HOMEHOST|AUTO)/P;D' $1 > $2
fi
}