summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian-conffile-location.diff10
-rw-r--r--debian/patches/debian-no-Werror.diff2
-rw-r--r--debian/patches/readlink-path.patch8
3 files changed, 13 insertions, 7 deletions
diff --git a/debian/patches/debian-conffile-location.diff b/debian/patches/debian-conffile-location.diff
index 8adf7b7e..e3b3e9bf 100644
--- a/debian/patches/debian-conffile-location.diff
+++ b/debian/patches/debian-conffile-location.diff
@@ -19,7 +19,7 @@ Reviewed-by: martin f. krafft <madduck@debian.org>
--- a/Makefile
+++ b/Makefile
-@@ -62,8 +62,8 @@
+@@ -68,8 +68,8 @@
PKG_CONFIG ?= pkg-config
SYSCONFDIR = /etc
@@ -32,7 +32,7 @@ Reviewed-by: martin f. krafft <madduck@debian.org>
# Both MAP_DIR and MDMON_DIR should be somewhere that persists across the
--- a/ReadMe.c
+++ b/ReadMe.c
-@@ -604,7 +604,7 @@
+@@ -609,7 +609,7 @@
;
char Help_config[] =
@@ -61,7 +61,7 @@ Reviewed-by: martin f. krafft <madduck@debian.org>
If the config file given is
.B "partitions"
then nothing will be read, but
-@@ -1888,9 +1888,9 @@
+@@ -1952,9 +1952,9 @@
or requested with (a possibly implicit)
.BR \-\-scan .
In the later case,
@@ -73,7 +73,7 @@ Reviewed-by: martin f. krafft <madduck@debian.org>
is used.
If
-@@ -3184,7 +3184,7 @@
+@@ -3276,7 +3276,7 @@
is given in Misc mode, and to monitor array reconstruction
on Monitor mode.
@@ -82,7 +82,7 @@ Reviewed-by: martin f. krafft <madduck@debian.org>
The config file lists which devices may be scanned to see if
they contain MD super block, and gives identifying information
-@@ -3192,7 +3192,7 @@
+@@ -3284,7 +3284,7 @@
.BR mdadm.conf (5)
for more details.
diff --git a/debian/patches/debian-no-Werror.diff b/debian/patches/debian-no-Werror.diff
index 7dcefd1a..6772cef3 100644
--- a/debian/patches/debian-no-Werror.diff
+++ b/debian/patches/debian-no-Werror.diff
@@ -13,7 +13,7 @@ Signed-off-by: martin f. krafft <madduck@debian.org>
--- a/Makefile
+++ b/Makefile
-@@ -43,7 +43,7 @@
+@@ -44,7 +44,7 @@
CC ?= $(CROSS_COMPILE)gcc
CXFLAGS ?= -ggdb
diff --git a/debian/patches/readlink-path.patch b/debian/patches/readlink-path.patch
index 86544592..9e68ea9f 100644
--- a/debian/patches/readlink-path.patch
+++ b/debian/patches/readlink-path.patch
@@ -10,6 +10,12 @@ it is /bin/readlink
--- a/udev-md-raid-arrays.rules
+++ b/udev-md-raid-arrays.rules
-@@ -38 +38 @@ ENV{MD_LEVEL}=="raid[1-9]*", ENV{SYSTEMD_WANTS}+="mdmonitor.service"
+@@ -35,7 +35,7 @@
+ ENV{MD_LEVEL}=="raid[1-9]*", ENV{SYSTEMD_WANTS}+="mdmonitor.service"
+
+ # Tell systemd to run mdmon for our container, if we need it.
-ENV{MD_LEVEL}=="raid[1-9]*", ENV{MD_CONTAINER}=="?*", PROGRAM="/usr/bin/readlink $env{MD_CONTAINER}", ENV{MD_MON_THIS}="%c"
+ENV{MD_LEVEL}=="raid[1-9]*", ENV{MD_CONTAINER}=="?*", PROGRAM="/bin/readlink $env{MD_CONTAINER}", ENV{MD_MON_THIS}="%c"
+ ENV{MD_MON_THIS}=="?*", PROGRAM="/usr/bin/basename $env{MD_MON_THIS}", ENV{SYSTEMD_WANTS}+="mdmon@%c.service"
+
+ LABEL="md_end"