summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 2 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 155948aa..2bc6ff72 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,12 +19,8 @@ endif
.PHONY: configure
configure:
-debian/mdadm-startall.8: debian/mdadm-startall.sgml
- docbook-to-man $< > $@.tmp
- mv $@.tmp $@
-
build: configure build-stamp
-build-stamp: debian/mdadm-startall.8
+build-stamp:
dh_testdir
$(MAKE) -f debian/rules mdadm.udeb DEBIAN=yes
$(MAKE) clean
@@ -52,7 +48,7 @@ clean:
rm -f $(INTERPOLATED_FILES)
rm -f build-stamp
[ ! -f Makefile ] || $(MAKE) clean
- rm -f mdadm.udeb mdmon.udeb mdadm debian/mdadm-startall.8
+ rm -f mdadm.udeb mdmon.udeb mdadm
dh_clean
debconf-updatepo
@@ -81,8 +77,6 @@ install: build $(INTERPOLATED_FILES)
install -Dm0755 debian/bugscript $(DESTDIR)/usr/share/bug/mdadm/script
install -Dm0644 debian/presubj $(DESTDIR)/usr/share/bug/mdadm/presubj
- install -Dm0755 debian/mdadm-startall $(DESTDIR)/sbin/mdadm-startall
-
install -Dm0755 mdadm.udeb $(DESTDIR_UDEB)/sbin/mdadm
install -Dm0755 mdmon.udeb $(DESTDIR_UDEB)/sbin/mdmon
install -Dm0644 udev-md-raid-arrays.rules $(DESTDIR_UDEB)/lib/udev/rules.d/63-md-raid-arrays.rules