summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mathys <eraserix@gmail.com>2018-10-02 21:58:02 +0200
committerAndrej Shadura <andrewsh@debian.org>2018-10-04 20:58:41 +0200
commitaded9f3d1f6f2691acd71f777f13251ce497c68b (patch)
tree8ad78f9ea1ded717ef8d3a8fabae4de4f1b567e6
parente5a040ef24ac434031d5cf60fba2cd9dddee2221 (diff)
parent01f9b8f3aff851d99b1108cb87e3b4b8bb7d2f21 (diff)
Import Debian changes 1.3.6-1debian/1.3.6-1archive/debian/1.3.6-1
mercurial-extension-utils (1.3.6-1) unstable; urgency=medium * New upstream release. * Bump compat to 11 without changes. * Increase std version to 4.2.1 without changes.
-rw-r--r--PKG-INFO3
-rw-r--r--README.txt1
-rw-r--r--debian/changelog8
-rw-r--r--debian/compat2
-rw-r--r--debian/control7
-rw-r--r--debian/copyright2
-rw-r--r--mercurial_extension_utils.egg-info/PKG-INFO3
-rw-r--r--mercurial_extension_utils.py9
-rw-r--r--setup.py2
9 files changed, 24 insertions, 13 deletions
diff --git a/PKG-INFO b/PKG-INFO
index b795ef9..58695fe 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: mercurial_extension_utils
-Version: 1.3.4
+Version: 1.3.6
Summary: Mercurial Extension Utils
Home-page: http://bitbucket.org/Mekk/mercurial-extension_utils
Author: Marcin Kasperski
@@ -14,7 +14,6 @@ Description: .. -*- mode: rst -*-
This module contains group of reusable functions, which I found useful
while writing Mercurial extensions.
- |drone-badge|
.. contents::
:local:
diff --git a/README.txt b/README.txt
index 47b40ab..11ff8b1 100644
--- a/README.txt
+++ b/README.txt
@@ -6,7 +6,6 @@ Mercurial Extension Utils
This module contains group of reusable functions, which I found useful
while writing Mercurial extensions.
-|drone-badge|
.. contents::
:local:
diff --git a/debian/changelog b/debian/changelog
index 7eebf95..16f23f5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mercurial-extension-utils (1.3.6-1) unstable; urgency=medium
+
+ * New upstream release.
+ * Bump compat to 11 without changes.
+ * Increase std version to 4.2.1 without changes.
+
+ -- Christoph Mathys <eraserix@gmail.com> Tue, 02 Oct 2018 21:58:02 +0200
+
mercurial-extension-utils (1.3.4-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/compat b/debian/compat
index f599e28..b4de394 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-10
+11
diff --git a/debian/control b/debian/control
index 60af610..0eaf564 100644
--- a/debian/control
+++ b/debian/control
@@ -2,11 +2,12 @@ Source: mercurial-extension-utils
Section: python
Priority: optional
Maintainer: Christoph Mathys <eraserix@gmail.com>
-Build-Depends: debhelper (>= 10), python-all (>= 2.6.6-3~),
+Build-Depends: debhelper (>= 11), python-all (>= 2.6.6-3~),
python-setuptools, dh-python
-Standards-Version: 3.9.8
+Standards-Version: 4.2.1
Homepage: http://pypi.python.org/pypi/mercurial_extension_utils
-X-Python-Version: >= 2.4
+X-Python-Version: all
+XB-Python-Version: ${python:Versions}
Package: mercurial-extension-utils
Architecture: all
diff --git a/debian/copyright b/debian/copyright
index fa95480..ac58945 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: mercurial-extension-utils
Source: http://pypi.python.org/pypi/mercurial_extension-utils
diff --git a/mercurial_extension_utils.egg-info/PKG-INFO b/mercurial_extension_utils.egg-info/PKG-INFO
index c2e7609..d33468a 100644
--- a/mercurial_extension_utils.egg-info/PKG-INFO
+++ b/mercurial_extension_utils.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: mercurial-extension-utils
-Version: 1.3.4
+Version: 1.3.6
Summary: Mercurial Extension Utils
Home-page: http://bitbucket.org/Mekk/mercurial-extension_utils
Author: Marcin Kasperski
@@ -14,7 +14,6 @@ Description: .. -*- mode: rst -*-
This module contains group of reusable functions, which I found useful
while writing Mercurial extensions.
- |drone-badge|
.. contents::
:local:
diff --git a/mercurial_extension_utils.py b/mercurial_extension_utils.py
index c82499d..62e916c 100644
--- a/mercurial_extension_utils.py
+++ b/mercurial_extension_utils.py
@@ -1010,8 +1010,13 @@ def direct_import_ext(module_name, blocked_modules=None):
from mercurial import demandimport
if blocked_modules:
for blocked_module in blocked_modules:
- if blocked_module not in demandimport.ignore:
- demandimport.ignore.append(blocked_module)
+ if hasattr(demandimport, 'IGNORES'):
+ # Mercurial 4.7 introduced set demandimport.IGNORES
+ demandimport.IGNORES.add(blocked_module)
+ else:
+ # Earlier it was demandimport.ignore, a list
+ if blocked_module not in demandimport.ignore:
+ demandimport.ignore.append(blocked_module)
# Various attempts to define is_demandimport_enabled
try:
diff --git a/setup.py b/setup.py
index cae62e3..6e435da 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@
from setuptools import setup, find_packages
-VERSION = '1.3.4'
+VERSION = '1.3.6'
LONG_DESCRIPTION = open("README.txt").read()
INSTALL_REQUIRES = []