summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mathys <eraserix@gmail.com>2016-05-29 13:38:27 +0200
committerAndrej Shadura <andrewsh@debian.org>2018-10-04 21:01:30 +0200
commit7d91eae6d43914d291b96b40e8c5bfa305c6131e (patch)
tree17242e4e15f33acf0aaf3df082658858d4b964f7
parent6675f410bf9c0b1cb230a7426d21f951ece642da (diff)
parentac1df2a4cbd75521678e09bd4a832dc4b7cf9ac5 (diff)
Import Debian changes 1.1.3-1
mercurial-keyring (1.1.3-1) unstable; urgency=medium * New upstream release. * Update d/watch to use pypi.debian.net. * Policy bumped to 3.9.8 without changes.
-rw-r--r--HISTORY.txt6
-rw-r--r--PKG-INFO2
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/watch5
-rw-r--r--mercurial_keyring.egg-info/PKG-INFO2
-rw-r--r--mercurial_keyring.py12
-rw-r--r--setup.py2
8 files changed, 30 insertions, 9 deletions
diff --git a/HISTORY.txt b/HISTORY.txt
index 56eca41..78b9a47 100644
--- a/HISTORY.txt
+++ b/HISTORY.txt
@@ -1,4 +1,10 @@
+1.1.3
+~~~~~~~~~~~~~~~~~~
+
+Mercurial 3.8 compatibility for email over SSL/TLS (SMTPS/STARTTLS
+constructors changed). Should not spoil older versions.
+
1.1.2
~~~~~~~~~~~~~~~~~~
diff --git a/PKG-INFO b/PKG-INFO
index ed3df43..179f8f9 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: mercurial_keyring
-Version: 1.1.2
+Version: 1.1.3
Summary: Mercurial Keyring Extension
Home-page: http://bitbucket.org/Mekk/mercurial_keyring
Author: Marcin Kasperski
diff --git a/debian/changelog b/debian/changelog
index 64a782c..b68e075 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mercurial-keyring (1.1.3-1) unstable; urgency=medium
+
+ * New upstream release.
+ * Update d/watch to use pypi.debian.net.
+ * Policy bumped to 3.9.8 without changes.
+
+ -- Christoph Mathys <eraserix@gmail.com> Sun, 29 May 2016 13:38:27 +0200
+
mercurial-keyring (1.1.2-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index 33c0bb6..406244a 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: python
Priority: optional
Maintainer: Christoph Mathys <eraserix@gmail.com>
Build-Depends: debhelper (>= 9), python-all (>= 2.6.6-3~), python-setuptools, dh-python
-Standards-Version: 3.9.7
+Standards-Version: 3.9.8
Homepage: http://pypi.python.org/pypi/mercurial_keyring
X-Python-Version: >= 2.4
diff --git a/debian/watch b/debian/watch
index fc50553..37926f7 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,4 +1,3 @@
version=3
-opts="filenamemangle=s/\S+\/([^\/]+\.tar\.gz)#md5=[[:alnum:]]+$/$1/" \
-https://pypi.python.org/simple/mercurial-keyring/ \
-\S+/mercurial_keyring-(\S+)\.tar\.gz#md5=[[:alnum:]]+
+opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
+https://pypi.debian.net/mercurial_keyring/mercurial_keyring-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))
diff --git a/mercurial_keyring.egg-info/PKG-INFO b/mercurial_keyring.egg-info/PKG-INFO
index 5133ae5..412faad 100644
--- a/mercurial_keyring.egg-info/PKG-INFO
+++ b/mercurial_keyring.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: mercurial-keyring
-Version: 1.1.2
+Version: 1.1.3
Summary: Mercurial Keyring Extension
Home-page: http://bitbucket.org/Mekk/mercurial_keyring
Author: Marcin Kasperski
diff --git a/mercurial_keyring.py b/mercurial_keyring.py
index 7f07fb5..d6dc31d 100644
--- a/mercurial_keyring.py
+++ b/mercurial_keyring.py
@@ -623,9 +623,17 @@ def keyring_supported_smtp(ui, username):
sslkwargs = {}
if smtps:
ui.note(_('(using smtps)\n'))
- s = SMTPS(sslkwargs, local_hostname=local_hostname)
+
+ # mercurial 3.8 added a mandatory host arg
+ if 'host' in SMTPS.__init__.__code__.co_varnames:
+ s = SMTPS(sslkwargs, local_hostname=local_hostname, host=mailhost)
+ else:
+ s = SMTPS(sslkwargs, local_hostname=local_hostname)
elif starttls:
- s = STARTTLS(sslkwargs, local_hostname=local_hostname)
+ if 'host' in STARTTLS.__init__.__code__.co_varnames:
+ s = STARTTLS(sslkwargs, local_hostname=local_hostname, host=mailhost)
+ else:
+ s = STARTTLS(sslkwargs, local_hostname=local_hostname)
else:
s = smtplib.SMTP(local_hostname=local_hostname)
if smtps:
diff --git a/setup.py b/setup.py
index a96df54..723cc60 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,5 @@
-VERSION = '1.1.2'
+VERSION = '1.1.3'
# pylint: disable=unused-import