summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Geissert <geissert@debian.org>2009-07-05 19:38:05 -0500
committerDmitry Bogatov <KAction@debian.org>2018-11-15 15:59:21 +0000
commitb4517d56e8360c424d41b4526f124b4800db5ad2 (patch)
tree734cc7f272c72deca1b5c4dfbb81ebac3572c1df
parentc6c24d035e375be8226d9c64b0c0589ac222cf30 (diff)
Import Debian changes 1.19-9.1
mini-httpd (1.19-9.1) unstable; urgency=low * Non-maintainer upload. * Fix bashism (Closes: #525366) * Fix lintian-detected hyphen-used-as-minus-sign errors. * Add watch file.
-rw-r--r--debian/changelog9
-rw-r--r--debian/mini-httpd.init.d4
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/05-manpage-hyphen.dpatch128
-rw-r--r--debian/watch2
5 files changed, 142 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 10ff0b1..b1a6fd9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+mini-httpd (1.19-9.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Fix bashism (Closes: #525366)
+ * Fix lintian-detected hyphen-used-as-minus-sign errors.
+ * Add watch file.
+
+ -- Raphael Geissert <geissert@debian.org> Sun, 05 Jul 2009 19:38:05 -0500
+
mini-httpd (1.19-9) unstable; urgency=low
* Added kFreeBSD portin patch (Closes: #498368)
diff --git a/debian/mini-httpd.init.d b/debian/mini-httpd.init.d
index 6f70372..c9839a0 100644
--- a/debian/mini-httpd.init.d
+++ b/debian/mini-httpd.init.d
@@ -26,7 +26,7 @@ fi
set -e
# Functions
-function start {
+start() {
if [ "$START" = "1" ]
then
echo -n "Starting $DESC: "
@@ -39,7 +39,7 @@ function start {
fi
}
-function stop {
+stop() {
echo -n "Stopping $DESC: "
# Get pid number
if [ -e /var/run/$NAME.pid ]
diff --git a/debian/patches/00list b/debian/patches/00list
index e8bc235..dacb26e 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -2,3 +2,4 @@
02-makefile.dpatch
03-cgi-php.dpatch
04-kfreebsd.dpatch
+05-manpage-hyphen.dpatch
diff --git a/debian/patches/05-manpage-hyphen.dpatch b/debian/patches/05-manpage-hyphen.dpatch
new file mode 100644
index 0000000..9178f2a
--- /dev/null
+++ b/debian/patches/05-manpage-hyphen.dpatch
@@ -0,0 +1,128 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 05-manpage-hyphen.dpatch by Raphael Geissert <geissert@debian.org>
+##
+## DP: Escape minus signs as needed.
+
+@DPATCH@
+
+--- mini-httpd-1.19.orig/mini_httpd.8 2009-07-05 19:45:04.000000000 -0500
++++ mini-httpd-1.19/mini_httpd.8 2009-07-05 19:50:45.000000000 -0500
+@@ -107,7 +107,7 @@
+ .B -dd
+ Specifies a directory to chdir() to after chrooting.
+ If you're not chrooting, you might as well do a single chdir() with
+-the -d flag.
++the \-d flag.
+ If you are chrooting, this lets you put the web files in a subdirectory
+ of the chroot tree, instead of in the top level mixed in with the
+ chroot files.
+@@ -172,7 +172,7 @@
+ The config-file option name for this flag is "maxage".
+ .TP
+ .B -S
+-If mini_httpd is configured to do SSL/HTTPS, then the -S flag is available
++If mini_httpd is configured to do SSL/HTTPS, then the \-S flag is available
+ to enable this feature.
+ The config-file option name for this flag is "ssl".
+ .TP
+@@ -207,7 +207,7 @@
+ mini_httpd supports the CGI 1.1 spec.
+ .PP
+ In order for a CGI program to be run, its name must match the pattern
+-you specify with the -c flag
++you specify with the \-c flag
+ This is a simple shell-style filename pattern.
+ You can use * to match any string not including a slash,
+ or ** to match any string including slashes,
+@@ -255,12 +255,12 @@
+ Check your system's syslodg man page for how to do this.
+ In FreeBSD you would put something like this in /etc/rc.conf:
+ .nf
+- syslogd_flags="-l /usr/local/www/data/dev/log"
++ syslogd_flags="\-l /usr/local/www/data/dev/log"
+ .fi
+ Substitute in your own chroot tree's pathname, of course.
+ Don't worry about creating the log socket, syslogd wants to do that itself.
+ (You may need to create the dev directory.)
+-In Linux the flag is -a instead of -l, and there may be other differences.
++In Linux the flag is \-a instead of \-l, and there may be other differences.
+ .SH "MULTIHOMING"
+ .PP
+ Multihoming means using one machine to serve multiple hostnames.
+@@ -308,7 +308,7 @@
+ probably out of luck.
+ .PP
+ Third and last, you must set up mini_httpd to handle the multiple hosts.
+-The easiest way is with the -v flag.
++The easiest way is with the \-v flag.
+ This works with either CNAME multihosting or multiple-IP multihosting.
+ What it does is send each incoming request to a subdirectory based on the
+ hostname it's intended for.
+@@ -321,26 +321,26 @@
+ If you're using old-style multiple-IP multihosting, you should also create
+ symbolic links from the numeric addresses to the names, like so:
+ .nf
+- ln -s www.acme.com 192.100.66.1
+- ln -s www.joe.acme.com 192.100.66.200
+- ln -s www.jane.acme.com 192.100.66.201
++ ln \-s www.acme.com 192.100.66.1
++ ln \-s www.joe.acme.com 192.100.66.200
++ ln \-s www.jane.acme.com 192.100.66.201
+ .fi
+ This lets the older HTTP/1.0 browsers find the right subdirectory.
+ .PP
+ There's an optional alternate step three if you're using multiple-IP
+ multihosting: run a separate mini_httpd process for each hostname, using
+-the -h flag to specify which one is which.
++the \-h flag to specify which one is which.
+ This gives you more flexibility, since you can run each of these processes
+ in separate directories or with different options.
+ Example:
+ .nf
+- ( cd /usr/www ; mini_httpd -h www.acme.com )
+- ( cd /usr/www/joe ; mini_httpd -u joe -h www.joe.acme.com )
+- ( cd /usr/www/jane ; mini_httpd -u jane -h www.jane.acme.com )
++ ( cd /usr/www ; mini_httpd \-h www.acme.com )
++ ( cd /usr/www/joe ; mini_httpd \-u joe \-h www.joe.acme.com )
++ ( cd /usr/www/jane ; mini_httpd \-u jane \-h www.jane.acme.com )
+ .fi
+ But remember, this multiple-process method does not work with CNAME
+-multihosting - for that, you must use a single mini_httpd process with
+-the -v flag.
++multihosting \(hy for that, you must use a single mini_httpd process with
++the \-v flag.
+ .SH "CUSTOM ERRORS"
+ .PP
+ mini_httpd lets you define your own custom error pages for the various
+@@ -416,15 +416,15 @@
+ You can also create one for yourself, using the openssl tool.
+ Step one - create the key and certificate request:
+ .nf
+- openssl req -new > cert.csr
++ openssl req \-new > cert.csr
+ .fi
+-Step two - remove the passphrase from the key:
++Step two \(hy remove the passphrase from the key:
+ .nf
+- openssl rsa -in privkey.pem -out key.pem
++ openssl rsa \-in privkey.pem \-out key.pem
+ .fi
+-Step three - convert the certificate request into a signed certificate:
++Step three \(hy convert the certificate request into a signed certificate:
+ .nf
+- openssl x509 -in cert.csr -out cert.pem -req -signkey key.pem -days 365
++ openssl x509 \-in cert.csr \-out cert.pem \-req \-signkey key.pem \-days 365
+ .fi
+ This creates four files.
+ The ones you want are cert.pem and key.pem.
+--- mini-httpd-1.19.orig/htpasswd.1 1999-09-28 13:49:35.000000000 -0500
++++ mini-httpd-1.19/htpasswd.1 2009-07-05 19:57:50.000000000 -0500
+@@ -9,7 +9,7 @@
+ .SH DESCRIPTION
+ .PP
+ Sets a user's password in an httpd-style password file.
+-The -c flag creates a new file.
++The \-c flag creates a new file.
+ .SH AUTHOR
+ Rob McCool.
+ Modified 29aug97 by Jef Poskanzer to accept new password on stdin,
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..7614601
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://www.acme.com/software/mini_httpd/mini_httpd-(.+)\.tar\.gz