summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarvin Stark <marv@der-marv.de>2008-02-05 08:56:53 +0000
committerDmitry Bogatov <KAction@debian.org>2018-11-15 15:59:20 +0000
commitdb330a20a902944294494fc16f67d6dcd1affee2 (patch)
tree4b2b89f83c76a1be1e6c0fb92e3205ad4889eef7
parent61e0abce903f44e0e7a6cc6cac5bf23d8b5dbf33 (diff)
Import Debian changes 1.19-7
mini-httpd (1.19-7) unstable; urgency=low * Patched PHP CGI errors (Closes: #462930) Thanks to Thorsten Schmale * Changed Standards-Version to 3.7.3 * Fixed init.d script
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rw-r--r--debian/mini-httpd.init.d2
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/03-cgi-php.dpatch37
5 files changed, 49 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 6ba5d63..894f302 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+mini-httpd (1.19-7) unstable; urgency=low
+
+ * Patched PHP CGI errors (Closes: #462930)
+ Thanks to Thorsten Schmale
+ * Changed Standards-Version to 3.7.3
+ * Fixed init.d script
+
+ -- Marvin Stark <marv@der-marv.de> Tue, 05 Feb 2008 08:56:53 +0000
+
mini-httpd (1.19-6) unstable; urgency=low
* Changed start behavior in default file (Closes: #454230)
diff --git a/debian/control b/debian/control
index dc57c2f..70148f3 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: web
Priority: optional
Maintainer: Marvin Stark <marv@der-marv.de>
Build-Depends: debhelper (>= 4), dpatch, libssl-dev
-Standards-Version: 3.7.2
+Standards-Version: 3.7.3
Package: mini-httpd
Architecture: any
diff --git a/debian/mini-httpd.init.d b/debian/mini-httpd.init.d
index 7ac3e48..a9ed23b 100644
--- a/debian/mini-httpd.init.d
+++ b/debian/mini-httpd.init.d
@@ -4,7 +4,7 @@
# Required-Start: $local_fs
# Required-Stop: $local_fs
# Default-Start: 2 3 4 5
-# Default-Stop: S 0 1 6
+# Default-Stop: 0 1 6
# Short-Description: mini-httpd start script
# Description: this script starts mini-httpd
### END INIT INFO
diff --git a/debian/patches/00list b/debian/patches/00list
index 67d0a1a..b2abd9f 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,2 +1,3 @@
01-manpage.dpatch
02-makefile.dpatch
+03-cgi-php.dpatch
diff --git a/debian/patches/03-cgi-php.dpatch b/debian/patches/03-cgi-php.dpatch
new file mode 100644
index 0000000..ddb8155
--- /dev/null
+++ b/debian/patches/03-cgi-php.dpatch
@@ -0,0 +1,37 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 02-cgi-php.dpatch by Marvin Stark <marv@der-marv.de>
+## Thanks to Thorsten Schmale who has written this patch.
+##
+## DP: mini_httpd does not run php cgi's.
+## DP: mini_httpd shows following error: "No input file specified".
+
+@DPATCH@
+
+--- mini-httpd-1.19/mini_httpd.c.orig 2008-02-05 08:40:28.000000000 +0000
++++ mini-httpd-1.19/mini_httpd.c 2008-02-05 08:50:35.000000000 +0000
+@@ -1129,7 +1129,7 @@
+ int r, file_len, i;
+ const char* index_names[] = {
+ "index.html", "index.htm", "index.xhtml", "index.xht", "Default.htm",
+- "index.cgi" };
++ "index.cgi", "index.php" };
+
+ /* Set up the timeout for reading. */
+ #ifdef HAVE_SIGSET
+@@ -2117,6 +2117,7 @@
+ int envn;
+ char* cp;
+ char buf[256];
++ char rp[MAXPATHLEN];
+
+ envn = 0;
+ envp[envn++] = build_env( "PATH=%s", CGI_PATH );
+@@ -2134,7 +2135,7 @@
+ envp[envn++] = build_env( "SERVER_PORT=%s", buf );
+ envp[envn++] = build_env(
+ "REQUEST_METHOD=%s", get_method_str( method ) );
+- envp[envn++] = build_env( "SCRIPT_NAME=%s", path );
++ envp[envn++] = build_env( "SCRIPT_FILENAME=%s", realpath(file, rp) );
+ if ( pathinfo != (char*) 0 )
+ {
+ envp[envn++] = build_env( "PATH_INFO=/%s", pathinfo );