summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJari Aalto <jari.aalto@cante.net>2010-01-07 11:13:26 +0200
committerDmitry Bogatov <KAction@debian.org>2018-11-15 15:59:22 +0000
commit185e47800f5f79d792aa3050f9d2ceb2f7c2e00a (patch)
treea622583ab295a3a48d2020b30e990df1a83fad41
parentb4517d56e8360c424d41b4526f124b4800db5ad2 (diff)
Import Debian changes 1.19-9.2
mini-httpd (1.19-9.2) unstable; urgency=medium [Jari Aalto] * Non-maintainer upload. * debian/patches - (number 10): New patch to fix htpasswd.c:52: error: conflicting types for 'getline'. . Thanks to Ruben Molina <rmolina@udea.edu.co>. (FTBFS RC Bug serious; Closes: #552844)
-rw-r--r--debian/changelog11
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/10-bug-552844-ftbfs-htpasswd.c-onflicting-types.dpatch28
3 files changed, 40 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b1a6fd9..9f78ff1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+mini-httpd (1.19-9.2) unstable; urgency=medium
+
+ [Jari Aalto]
+ * Non-maintainer upload.
+ * debian/patches
+ - (number 10): New patch to fix htpasswd.c:52: error:
+ conflicting types for 'getline'. . Thanks to Ruben Molina
+ <rmolina@udea.edu.co>. (FTBFS RC Bug serious; Closes: #552844)
+
+ -- Jari Aalto <jari.aalto@cante.net> Thu, 07 Jan 2010 11:13:26 +0200
+
mini-httpd (1.19-9.1) unstable; urgency=low
* Non-maintainer upload.
diff --git a/debian/patches/00list b/debian/patches/00list
index dacb26e..a3a2cb2 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -3,3 +3,4 @@
03-cgi-php.dpatch
04-kfreebsd.dpatch
05-manpage-hyphen.dpatch
+10-bug-552844-ftbfs-htpasswd.c-onflicting-types.dpatch
diff --git a/debian/patches/10-bug-552844-ftbfs-htpasswd.c-onflicting-types.dpatch b/debian/patches/10-bug-552844-ftbfs-htpasswd.c-onflicting-types.dpatch
new file mode 100644
index 0000000..1fe5f5f
--- /dev/null
+++ b/debian/patches/10-bug-552844-ftbfs-htpasswd.c-onflicting-types.dpatch
@@ -0,0 +1,28 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## ../bug-552844-ftbfs-htpasswd.c-onflicting-types.dpatch by <jari.aalto@cante.net>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Bug#552844 FTBFS: htpasswd.c:52: error: conflicting types for getline
+
+@DPATCH@
+
+--- mini-httpd-1.19.orig/htpasswd.c
++++ mini-httpd-1.19/htpasswd.c
+@@ -49,7 +49,7 @@
+ while((line[y++] = line[x++]));
+ }
+
+-static int getline(char *s, int n, FILE *f) {
++static int mygetline(char *s, int n, FILE *f) {
+ register int i=0;
+
+ while(1) {
+@@ -189,7 +189,7 @@
+ strcpy(user,argv[2]);
+
+ found = 0;
+- while(!(getline(line,MAX_STRING_LEN,f))) {
++ while(!(mygetline(line,MAX_STRING_LEN,f))) {
+ if(found || (line[0] == '#') || (!line[0])) {
+ putline(tfp,line);
+ continue;