summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSebastian Andrzej Siewior <sebastian@breakpoint.cc>2017-02-16 23:14:13 +0100
committerDmitry Bogatov <KAction@debian.org>2018-11-15 15:59:24 +0000
commite68f4a9a5d2b38573878f54c1e175c14140813aa (patch)
tree8d52e2e3107674003d6456106257656fbc438f62 /debian
parent0b44d3f4e5a20b66d82b6346e9ec383e80f9a3fa (diff)
Import Debian changes 1.23-1.2
mini-httpd (1.23-1.2) unstable; urgency=medium * Non-maintainer upload. * Bring back lost HTTPS support (Closes: #818474).
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/fix-makefile20
2 files changed, 19 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 5dde5f1..0e5abb5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+mini-httpd (1.23-1.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Bring back lost HTTPS support (Closes: #818474).
+
+ -- Sebastian Andrzej Siewior <sebastian@breakpoint.cc> Thu, 16 Feb 2017 23:14:13 +0100
+
mini-httpd (1.23-1.1) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/patches/fix-makefile b/debian/patches/fix-makefile
index 17a8d60..a1054a1 100644
--- a/debian/patches/fix-makefile
+++ b/debian/patches/fix-makefile
@@ -2,11 +2,13 @@ Description: Change DESTDIR and LCFLAGS
Autor: Jose dos Santos Junior <j.s.junior@live.com>
Last-Update: 2015-09-05
===================================================================
-Index: mini-httpd-1.21/Makefile
-===================================================================
---- mini-httpd-1.21.orig/Makefile
-+++ mini-httpd-1.21/Makefile
-@@ -19,13 +19,12 @@ CRYPT_LIB = -lcrypt
+---
+ Makefile | 15 ++++++---------
+ 1 file changed, 6 insertions(+), 9 deletions(-)
+
+--- a/Makefile
++++ b/Makefile
+@@ -19,22 +19,21 @@ CRYPT_LIB = -lcrypt
#SSL_INC = -I$(SSL_TREE)/include
#SSL_LIBS = -L$(SSL_TREE)/lib -lssl -lcrypto
@@ -20,12 +22,14 @@ Index: mini-httpd-1.21/Makefile
-CFLAGS = -O $(CDEFS) -ansi -pedantic -U__STRICT_ANSI__ -Wall -Wpointer-arith -Wshadow -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wno-long-long
-LDFLAGS = -s
+CFLAGS+=-O $(CDEFS) -ansi -pedantic -U__STRICT_ANSI__ -Wall -Wpointer-arith -Wshadow -Wcast-qual -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wno-long-long
-+LDFLAGS+= -s `dpkg-buildflags --get CPPFLAGS` `dpkg-buildflags --get CFLAGS` `dpkg-buildflags --get LDFLAGS`
++LDFLAGS+= -s `dpkg-buildflags --get CPPFLAGS` `dpkg-buildflags --get CFLAGS` `dpkg-buildflags --get LDFLAGS` -DUSE_SSL
LDLIBS = $(CRYPT_LIB) $(SSL_LIBS) $(SYSV_LIBS)
all: mini_httpd htpasswd
-@@ -34,7 +33,7 @@ mini_httpd: mini_httpd.o match.o tdate_p
- $(CC) $(LDFLAGS) mini_httpd.o match.o tdate_parse.o $(LDLIBS) -o mini_httpd
+
+ mini_httpd: mini_httpd.o match.o tdate_parse.o
+- $(CC) $(LDFLAGS) mini_httpd.o match.o tdate_parse.o $(LDLIBS) -o mini_httpd
++ $(CC) $(LDFLAGS) mini_httpd.o match.o tdate_parse.o $(LDLIBS) -o mini_httpd -lssl -lcrypto
mini_httpd.o: mini_httpd.c version.h port.h match.h tdate_parse.h mime_encodings.h mime_types.h
- $(CC) $(CFLAGS) -c mini_httpd.c