summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/config/mini_httpd.conf36
-rw-r--r--debian/control19
-rw-r--r--debian/copyright28
-rw-r--r--debian/docs3
-rw-r--r--debian/mini_httpd.default8
-rw-r--r--debian/mini_httpd.init.d57
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/01-manpage.dpatch18
-rwxr-xr-xdebian/rules65
11 files changed, 241 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..18bcaf9
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+mini-httpd (1.19-1) unstable; urgency=low
+
+ * Initial release (Closes: #376599, #308660).
+
+ -- Marvin Stark <marv@der-marv.de> Mon, 3 Jul 2006 20:12:42 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/config/mini_httpd.conf b/debian/config/mini_httpd.conf
new file mode 100644
index 0000000..534f522
--- /dev/null
+++ b/debian/config/mini_httpd.conf
@@ -0,0 +1,36 @@
+# Example config for mini_httpd.
+# Author: Marvin Stark <marv@der-marv.de>
+
+# Uncomment this line for turning on ssl support.
+#ssl
+
+# On which host mini_httpd should bind?
+host=localhost
+
+# On which port mini_httpd should listen?
+port=80
+
+# Which user mini_httpd should use?
+user=nobody
+
+# Run in chroot mode?
+#chroot # yes
+nochroot # no
+
+# Working directory of mini_httpd.
+#dir=<work_dir>
+
+# We are the web files stored?
+data_dir=/etc/mini_httpd
+
+# Which certificate to use?
+#certfile=<certfile>
+
+# Which logfile to use?
+logfile=/var/log/mini_httpd.log
+
+# Which pidfile to use?
+pidfile=/var/run/mini_httpd.pid
+
+# Which charset to use?
+charset=iso-8859-1
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..b3d99b0
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,19 @@
+Source: mini-httpd
+Section: web
+Priority: optional
+Maintainer: Marvin Stark <marv@der-marv.de>
+Uploaders: Daniel Baumann <daniel@debian.org>
+Build-Depends: debhelper (>= 4), dpatch, libssl-dev
+Standards-Version: 3.7.2
+
+Package: mini-httpd
+Architecture: any
+Depends: ${shlibs:Depends}
+Provides: httpd, httpd-cgi
+Description: a small HTTP server
+ mini_httpd implements all basic features of a HTTPD, including: GET,HEAD,POST
+ methods, common MIME types, basic authentication, virtual hosting, CGI,
+ directory listing, trailing-slash redirection, standard logging, custom error
+ pages etc. It also can be configured to do SSL and IPv6.
+ .
+ Homepage: <http://www.acme.com/software/mini_httpd>
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..73460d0
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,28 @@
+This package was debianized by Marvin Stark <marv@der-marv.de> on
+Mon, 3 Jul 2006 20:12:42 +0200.
+
+It was downloaded from <http://www.acme.com/software/mini_httpd/>.
+
+Copyright Holder: Jef Poskanzer <jef@acme.com>
+
+License:
+
+ Copyright (C) 1999-2000 Jef Poskanzer <jef@acme.com>
+
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted under the terms of the BSD License.
+
+ THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS
+ BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
+ THE POSSIBILITY OF SUCH DAMAGE.
+
+On Debian systems, the complete text of the BSD License
+can be found in `/usr/share/common-licenses/BSD'.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..d347ec9
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,3 @@
+README
+mime_encodings.txt
+mime_types.txt
diff --git a/debian/mini_httpd.default b/debian/mini_httpd.default
new file mode 100644
index 0000000..efe5856
--- /dev/null
+++ b/debian/mini_httpd.default
@@ -0,0 +1,8 @@
+# Defaults for mini_httpd initscript
+# Author: Marvin Stark <marv@der-marv.de>
+
+# Start daemon?
+START=0
+
+# Additional options that are passed to the Daemon.
+DAEMON_OPTS="-C /etc/mini_httpd.conf"
diff --git a/debian/mini_httpd.init.d b/debian/mini_httpd.init.d
new file mode 100644
index 0000000..807cb90
--- /dev/null
+++ b/debian/mini_httpd.init.d
@@ -0,0 +1,57 @@
+#! /bin/sh
+
+# Globals
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/mini_httpd
+NAME=mini_httpd
+DESC="web server"
+
+test -x $DAEMON || exit 0
+
+# Include mini_httd defaults if available
+if [ -f /etc/default/mini_httpd ]
+then
+ . /etc/default/mini_httpd
+fi
+
+set -e
+
+case "$1" in
+ start)
+ if [ "$START" = "0" ]
+ then
+ echo -n "Starting $DESC: "
+ start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid \
+ --exec $DAEMON -- $DAEMON_OPTS
+ echo "$NAME."
+ fi
+ ;;
+
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon --stop --quiet --pidfile /var/run/$NAME.pid \
+ --exec $DAEMON
+ echo "$NAME."
+ ;;
+
+ restart|force-reload)
+ echo -n "Restarting $DESC: "
+ if [ "$START" = "0" ]
+ then
+ start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid \
+ --exec $DAEMON -- $DAEMON_OPTS
+ fi
+ sleep 1
+ start-stop-daemon --start --quiet --pidfile \
+ /var/run/$NAME.pid --exec $DAEMON -- $DAEMON_OPTS
+ echo "$NAME."
+ ;;
+
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/debian/patches/00list b/debian/patches/00list
new file mode 100644
index 0000000..54ee151
--- /dev/null
+++ b/debian/patches/00list
@@ -0,0 +1 @@
+01-manpage.dpatch
diff --git a/debian/patches/01-manpage.dpatch b/debian/patches/01-manpage.dpatch
new file mode 100644
index 0000000..0688334
--- /dev/null
+++ b/debian/patches/01-manpage.dpatch
@@ -0,0 +1,18 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 01-manpage.dpatch by Marvin Stark <marv@der-marv.de>
+##
+## DP: Fix manpage character error.
+
+@DPATCH@
+
+--- mini-httpd-1.19/mini_httpd.8.orig 2006-07-05 00:14:37.000000000 +0200
++++ mini-httpd-1.19/mini_httpd.8 2006-07-05 00:15:30.000000000 +0200
+@@ -432,7 +432,7 @@
+ .SH "SEE ALSO"
+ htpasswd(1), weblog_parse(1), http_get(1)
+ .SH AUTHOR
+-Copyright © 1999,2000 by Jef Poskanzer <jef@mail.acme.com>. All rights reserved.
++Copyright \[co] 1999,2000 by Jef Poskanzer <jef\[at]mail.acme.com>. All rights reserved.
+ .\" Redistribution and use in source and binary forms, with or without
+ .\" modification, are permitted provided that the following conditions
+ .\" are met:
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b99c1c9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,65 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+include /usr/share/dpatch/dpatch.make
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+build: patch
+
+clean: unpatch
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ -$(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ CFLAGS="$(CFLAGS)" $(MAKE) install BINDIR="debian/mini-httpd/usr/sbin" \
+ MANDIR="debian/mini-httpd/usr/share/man" \
+ SSL_TREE="/usr" \
+ SSL_DEFS="-DUSE_SSL" \
+ SSL_INC="-I${SSL_TREE}/include/openssl" \
+ SSL_LIBS="-L${SSL_TREE}/lib -lssl -lcrypto"
+
+ # Moving htpasswd to its designated directory.
+ install -d -m 0755 debian/mini-httpd/usr/bin
+ mv debian/mini-httpd/usr/sbin/htpasswd debian/mini-httpd/usr/bin
+
+ # Moving example configuration to its designated directory.
+ install -D -m 0644 debian/config/mini_httpd.conf debian/mini-httpd/etc/mini_httpd.conf
+
+binary-indep: build install
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installinit --name mini_httpd
+ dh_link
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install