summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Kogan <dima@secretsauce.net>2019-03-10 13:15:20 -0700
committerAndrej Shadura <andrewsh@debian.org>2019-04-13 17:30:39 +0200
commit2dc78168060aeb81269c0a84412355e2ad5ae75b (patch)
treebdd9512145807d15a5668fa2a38df4665c9977bc
parent4540bd6a5db4239cffcf70c628b6d666a3e3a266 (diff)
Split .dot into two separate files
dot has a bug: graphs spanning multiple pages contain incorrect PostScript. This is an upstream bug in graphviz. This patch a workaround for mk-configure. This splits up the offending .dot file into two separate .dot files, each with a single graph. Closes: #895320
-rw-r--r--presentation/Makefile4
-rw-r--r--presentation/my_prjs1.dot (renamed from presentation/my_prjs.dot)8
-rw-r--r--presentation/my_prjs2.dot7
-rw-r--r--presentation/presentation.tex5
4 files changed, 13 insertions, 11 deletions
diff --git a/presentation/Makefile b/presentation/Makefile
index cdafd80..fb621dc 100644
--- a/presentation/Makefile
+++ b/presentation/Makefile
@@ -13,7 +13,7 @@ dvi : presentation.dvi
.SUFFIXES: .ps .eps .pdf .dvi .tex .dot
-presentation.ps presentation.pdf presentation.dvi: my_prjs.eps dep_graph.eps
+presentation.ps presentation.pdf presentation.dvi: my_prjs1.eps my_prjs2.eps dep_graph.eps
.ps.pdf:
${PROG.${PS2PDF}} "$<" "$@"
@@ -44,6 +44,6 @@ clean-garbage:
myprojects.tex : presentation.tex
awk '/^%%%begin-myprojects/, /^%%%end-myprojects/' \
${.ALLSRC} > ${.TARGET}
-myprojects.ps myprojects.pdf myprojects.dvi: my_prjs.eps
+myprojects.ps myprojects.pdf myprojects.dvi: my_prjs1.eps my_prjs2.eps
.include <mkc.mk>
diff --git a/presentation/my_prjs.dot b/presentation/my_prjs1.dot
index e2bcfe0..14a799c 100644
--- a/presentation/my_prjs.dot
+++ b/presentation/my_prjs1.dot
@@ -42,11 +42,3 @@ digraph FSA {
"pipestatus" -> "pkg_summary-utils";
}
-
-digraph FSA {
- graph [ ratio=compress layout=dot rankdir=UB ratio=0.4 ];
-
- node [ shape = hexagon style=filled fontsize=20 ];
- "lua-alt-getopt";
- "judyhash";
-}
diff --git a/presentation/my_prjs2.dot b/presentation/my_prjs2.dot
new file mode 100644
index 0000000..d4639cc
--- /dev/null
+++ b/presentation/my_prjs2.dot
@@ -0,0 +1,7 @@
+digraph FSA {
+ graph [ ratio=compress layout=dot rankdir=UB ratio=0.4 ];
+
+ node [ shape = hexagon style=filled fontsize=20 ];
+ "lua-alt-getopt";
+ "judyhash";
+}
diff --git a/presentation/presentation.tex b/presentation/presentation.tex
index 0a388f3..449dc44 100644
--- a/presentation/presentation.tex
+++ b/presentation/presentation.tex
@@ -1256,7 +1256,10 @@ hello: ELF 64-bit MSB executable, SPARC V9, relaxed
\begin{block}{My opensource projects using
mk-configure (filled hexagon), Mk files (box) and others (oval)}
\begin{figure}
- \includegraphics[width=\textwidth, height=0.60\textheight, keepaspectratio=false]{my_prjs.eps}
+ \includegraphics[width=\textwidth, height=0.60\textheight, keepaspectratio=false]{my_prjs1.eps}
+ \end{figure}
+ \begin{figure}
+ \includegraphics[width=\textwidth, height=0.60\textheight, keepaspectratio=false]{my_prjs1.eps}
\end{figure}
% \begin{figure}
% \includegraphics[width=0.7\textwidth, height=0.10\textwidth, keepaspectratio=false]{my_prjs2.eps}