summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-02-18 22:05:01 +0100
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:41 +0200
commite95ea4c40113360de58a71b7df0a1f8aa4e0cf21 (patch)
tree7a54db794c8e5571b2122e6e2145e360dca05173 /debian
parentc8659b636be5e763c5dc028a5db7294b1af2648c (diff)
parent6ec061aabc159e3f37591e92fa1df407cdca6246 (diff)
Imported Debian patch 0.26.0-1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control6
-rw-r--r--debian/copyright57
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules8
-rw-r--r--debian/watch2
6 files changed, 79 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 9003a9b..c921076 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+mk-configure (0.26.0-1) unstable; urgency=low
+
+ * New upstream release.
+ * Update watch file.
+ * Ship presentation.pdf.
+ * Recommend pkg-config.
+
+ -- Andrew Shadura <andrewsh@debian.org> Tue, 18 Feb 2014 22:05:01 +0100
+
mk-configure (0.25.0-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/control b/debian/control
index 78eb9f2..d8e0cc1 100644
--- a/debian/control
+++ b/debian/control
@@ -2,12 +2,14 @@ Source: mk-configure
Section: devel
Priority: optional
Maintainer: Andrew Shadura <andrewsh@debian.org>
-Build-Depends: debhelper (>= 9), bmake (>= 20131001)
-Standards-Version: 3.9.4
+Build-Depends: debhelper (>= 9), bmake (>= 20131001),
+ graphviz, latex-beamer, texlive-latex-extra, texlive-fonts-recommended, ghostscript
+Standards-Version: 3.9.5
Package: mk-configure
Architecture: all
Depends: bmake, ${misc:Depends}
+Recommends: pkgconf | pkg-config
Description: lightweight replacement for GNU autotools
mk-configure is a lightweight easy-to-use replacement for GNU autotools,
written in bmake (portable version of NetBSD make) and POSIX tools (shell,
diff --git a/debian/copyright b/debian/copyright
index a5100cb..7b61bfb 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -148,7 +148,7 @@ purpose. It is provided "as is" without express or implied warranty.
######################################################################
-File examples/hello_strlcpy/strlcpy.c is licensed as follows:
+Files examples/hello_strlcpy/strlcpy.c and features/strl*/* are licensed as follows:
Copyright (c) 1998 Todd C. Miller <Todd.Miller@courtesan.com>
@@ -163,3 +163,58 @@ FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION
OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+######################################################################
+
+Files: features/netbsd_sys_tree.h
+Copyright: 2002 Niels Provos <provos@citi.umich.edu>
+License: BSD-2
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+ IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+ NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+ THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+######################################################################
+
+Files: features/netbsd_sys_queue.h
+Copyright: 1991, 1993 The Regents of the University of California. All rights reserved.
+License: BSD-3
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. Neither the name of the University nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ SUCH DAMAGE.
+
diff --git a/debian/docs b/debian/docs
index cb66f81..7c922dd 100644
--- a/debian/docs
+++ b/debian/docs
@@ -2,3 +2,4 @@ doc/FAQ
doc/NEWS
README
doc/TODO
+presentation/presentation.pdf
diff --git a/debian/rules b/debian/rules
index 9beccfd..a681599 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,14 @@ export MKFILESDIR := $(PREFIX)/share/mk-configure/mk
%:
dh $@ --buildsystem=bmake
+override_dh_auto_clean:
+ -dh_auto_clean
+ bmake cleandir-presentation
+
+override_dh_auto_build:
+ dh_auto_build
+ bmake pdf
+
override_dh_auto_test:
.PHONY: override_dh_auto_test
diff --git a/debian/watch b/debian/watch
index 6c39629..e87cb89 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,5 +1,5 @@
# Compulsory line, this is a version 3 file
version=3
-opts=filenamemangle=s/.*\/(.*)$/mk-configure-$1/ https://github.com/cheusov/mk-configure/tags /cheusov/mk-configure/archive/mk-configure-(\d.*).tar.gz
+http://mova.org/~cheusov/pub/mk-configure/mk-configure-(\d.*).tar.gz