summaryrefslogtreecommitdiff
path: root/examples/hello_TARGETS/Makefile
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:29 +0200
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:29 +0200
commitaba913436a8521abe405a04ed71388989e1d646f (patch)
tree0e2fea8c3ccf06ae3b370806810e382ca51f4a98 /examples/hello_TARGETS/Makefile
parent1d3d0bb1e461a81bc1a9cd4520958bd2b1db4c7f (diff)
Imported Upstream version 0.25.0
Diffstat (limited to 'examples/hello_TARGETS/Makefile')
-rw-r--r--examples/hello_TARGETS/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/examples/hello_TARGETS/Makefile b/examples/hello_TARGETS/Makefile
new file mode 100644
index 0000000..95fcf15
--- /dev/null
+++ b/examples/hello_TARGETS/Makefile
@@ -0,0 +1,15 @@
+SUBDIR = hello1 hello2
+
+# additional recursive target
+TARGETS += codingstylechk
+
+# We want to include man pages to the distribution tarball.
+# For this we do the following:
+# mkcmake manpages; tar -cf /tmp/tarball.tar .
+TARGETS += _manpages # _manpages is a new recursive target
+.PHONY: manpages
+manpages: _manpages
+ @rm ${MKC_CACHEDIR}/_mkc*
+
+.include "test.mk"
+.include <mkc.subdir.mk>