summaryrefslogtreecommitdiff
path: root/examples/hello_autoconf/test.mk
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-09-14 17:41:43 +0200
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:57 +0200
commit02e4dec7376d8e7b563b8008b979682b82b23e11 (patch)
tree18b1263e3a507d785fbde6a8a09e6e019ff986a8 /examples/hello_autoconf/test.mk
parent99305952b2affb1672b6f44834378729c753aab4 (diff)
parent7bea690e43ee009efc9e8f6a45504496348cd3ee (diff)
Imported Debian patch 0.28.0-1
Diffstat (limited to 'examples/hello_autoconf/test.mk')
-rw-r--r--examples/hello_autoconf/test.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/examples/hello_autoconf/test.mk b/examples/hello_autoconf/test.mk
new file mode 100644
index 0000000..8e6586e
--- /dev/null
+++ b/examples/hello_autoconf/test.mk
@@ -0,0 +1,27 @@
+EXCL_RE='autom4te[.]cache'
+
+.PHONY : test_output
+test_output:
+ @ \
+ ${.OBJDIR}/hello_autoconf; \
+ rm -rf ${.OBJDIR}${PREFIX}; \
+ \
+ echo =========== all ============; \
+ find ${.OBJDIR} -type f | grep -Ev '${EXCL_RE}' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========== clean ===========; \
+ ${MAKE} ${MAKEFLAGS} clean > /dev/null; \
+ find ${.OBJDIR} -type f | grep -vE '${EXCL_RE}' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ echo ========== all SHRTOUT=yes ===========; \
+ ${MAKE} ${MAKEFLAGS} all SHRTOUT=yes | \
+ grep -E '^[[:alpha:]]+:'; \
+ \
+ echo ======= cleandir ==========; \
+ ${MAKE} ${MAKEFLAGS} cleandir > /dev/null; \
+ find ${.OBJDIR} -type f | grep -vE '${EXCL_RE}' | \
+ mkc_test_helper "${PREFIX}" "${.OBJDIR}"
+
+.include <mkc.minitest.mk>