summaryrefslogtreecommitdiff
path: root/examples/hello_customtests2/test.mk
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:29 +0200
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:29 +0200
commitaba913436a8521abe405a04ed71388989e1d646f (patch)
tree0e2fea8c3ccf06ae3b370806810e382ca51f4a98 /examples/hello_customtests2/test.mk
parent1d3d0bb1e461a81bc1a9cd4520958bd2b1db4c7f (diff)
Imported Upstream version 0.25.0
Diffstat (limited to 'examples/hello_customtests2/test.mk')
-rw-r--r--examples/hello_customtests2/test.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/examples/hello_customtests2/test.mk b/examples/hello_customtests2/test.mk
index 438e4ab..b3ce488 100644
--- a/examples/hello_customtests2/test.mk
+++ b/examples/hello_customtests2/test.mk
@@ -1,7 +1,10 @@
+CLEANDIRS += ${.CURDIR}/testdir
+
.PHONY : test_output
test_output:
@set -e; \
rm -rf ${.OBJDIR}${PREFIX}; \
+ MKCATPAGES=yes; export MKCATPAGES; \
\
echo =========== all ============; \
find ${.OBJDIR} -type f | \
@@ -11,13 +14,13 @@ test_output:
${.OBJDIR}/hello_customtests2; \
\
echo ========= install ==========; \
- ${MAKE} ${MAKEFLAGS} install DESTDIR=${.OBJDIR} \
+ ${MAKE} ${MAKEFLAGS} install -j3 DESTDIR=${.OBJDIR} \
> /dev/null; \
find ${.OBJDIR}${PREFIX} -type f -o -type d | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
\
echo ======== uninstall =========; \
- ${MAKE} ${MAKEFLAGS} uninstall DESTDIR=${.OBJDIR} > /dev/null; \
+ ${MAKE} ${MAKEFLAGS} -j4 uninstall DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR}${PREFIX} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
@@ -26,6 +29,11 @@ test_output:
find ${.OBJDIR} -type f | \
mkc_test_helper "${PREFIX}" "${.OBJDIR}";\
\
+ echo ======= errorcheck + MAKEOBJDIR ===========; \
+ mkdir ${.CURDIR}/testdir || true; \
+ ${MAKE} ${MAKEFLAGS} errorcheck MAKEOBJDIR=${.CURDIR}/testdir > /dev/null; \
+ printf 'true_is_available=%s\n' `cat ${.CURDIR}/testdir/_mkc_custom_true_is_available.res`; \
+ \
echo ======= distclean ==========; \
${MAKE} ${MAKEFLAGS} distclean DESTDIR=${.OBJDIR} > /dev/null; \
find ${.OBJDIR} -type f | \