summaryrefslogtreecommitdiff
path: root/examples/tools/Makefile
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-01-05 22:42:41 +0100
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:33 +0200
commitc8659b636be5e763c5dc028a5db7294b1af2648c (patch)
tree7dacf7580ff8c7d8c64682eaa28350bc47fbd56e /examples/tools/Makefile
parent004c4cd3db1d9ad252eccbc1e9e6c54ec61a2927 (diff)
parentaba913436a8521abe405a04ed71388989e1d646f (diff)
Imported Debian patch 0.25.0-1
Diffstat (limited to 'examples/tools/Makefile')
-rw-r--r--examples/tools/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/tools/Makefile b/examples/tools/Makefile
index 64f67a1..5077390 100644
--- a/examples/tools/Makefile
+++ b/examples/tools/Makefile
@@ -1,6 +1,16 @@
SUBPRJ = libs/foo:tools/prog1
SUBPRJ += libs/bar:tools/prog2
SUBPRJ += libs/foo:tools/prog3 libs/bar:tools/prog3
+SUBPRJ += libs/qux:tools/prog4
+
+# target "check" is used for testing because "test" is used by mk-configure
+TARGETS = check
+
+NODEPS += check-libs/*:check check-libs/*:check-tools/*
+
+# for regression test only
+_THISDIR_ =
+.export _THISDIR_
.include "test.mk"
.include <mkc.subprj.mk>