summaryrefslogtreecommitdiff
path: root/examples/tools/libs/foo
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:21 +0200
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:21 +0200
commit1d3d0bb1e461a81bc1a9cd4520958bd2b1db4c7f (patch)
tree1aa5b654ab4ab52e936550463aac7e4da0aad722 /examples/tools/libs/foo
Imported Upstream version 0.24.0
Diffstat (limited to 'examples/tools/libs/foo')
-rw-r--r--examples/tools/libs/foo/Makefile7
-rw-r--r--examples/tools/libs/foo/foo.c6
-rw-r--r--examples/tools/libs/foo/foo.h1
-rw-r--r--examples/tools/libs/foo/linkme.mk5
4 files changed, 19 insertions, 0 deletions
diff --git a/examples/tools/libs/foo/Makefile b/examples/tools/libs/foo/Makefile
new file mode 100644
index 0000000..0003bee
--- /dev/null
+++ b/examples/tools/libs/foo/Makefile
@@ -0,0 +1,7 @@
+LIB = foo
+SRCS = foo.c
+INCS = foo.h
+
+WARNS = 4
+
+.include <mkc.lib.mk>
diff --git a/examples/tools/libs/foo/foo.c b/examples/tools/libs/foo/foo.c
new file mode 100644
index 0000000..1d47523
--- /dev/null
+++ b/examples/tools/libs/foo/foo.c
@@ -0,0 +1,6 @@
+#include "foo.h"
+
+const char *get_msg1 (void)
+{
+ return "This is a message #";
+}
diff --git a/examples/tools/libs/foo/foo.h b/examples/tools/libs/foo/foo.h
new file mode 100644
index 0000000..489e95b
--- /dev/null
+++ b/examples/tools/libs/foo/foo.h
@@ -0,0 +1 @@
+const char *get_msg1 (void);
diff --git a/examples/tools/libs/foo/linkme.mk b/examples/tools/libs/foo/linkme.mk
new file mode 100644
index 0000000..00b5b42
--- /dev/null
+++ b/examples/tools/libs/foo/linkme.mk
@@ -0,0 +1,5 @@
+PATH.foo := ${.PARSEDIR}
+
+CPPFLAGS += -I${PATH.foo}
+DPLIBDIRS += ${PATH.foo}
+LDADD += -lfoo