summaryrefslogtreecommitdiff
path: root/features/mkc_imp.f_SLIST.mk
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-09-14 17:41:43 +0200
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:57 +0200
commit02e4dec7376d8e7b563b8008b979682b82b23e11 (patch)
tree18b1263e3a507d785fbde6a8a09e6e019ff986a8 /features/mkc_imp.f_SLIST.mk
parent99305952b2affb1672b6f44834378729c753aab4 (diff)
parent7bea690e43ee009efc9e8f6a45504496348cd3ee (diff)
Imported Debian patch 0.28.0-1
Diffstat (limited to 'features/mkc_imp.f_SLIST.mk')
-rw-r--r--features/mkc_imp.f_SLIST.mk15
1 files changed, 7 insertions, 8 deletions
diff --git a/features/mkc_imp.f_SLIST.mk b/features/mkc_imp.f_SLIST.mk
index c00abc6..d5a1fc4 100644
--- a/features/mkc_imp.f_SLIST.mk
+++ b/features/mkc_imp.f_SLIST.mk
@@ -2,7 +2,10 @@
#
# See LICENSE file in the distribution.
############################################################
-.include <mkc.configure.mk>
+.ifndef _MKC_IMP_F_SYSQUEUE_MK
+_MKC_IMP_F_SYSQUEUE_MK := 1
+
+.include <mkc_imp.conf-cleanup.mk>
_macro = SLIST SIMPLEQ STAILQ LIST TAILQ TAILQ
@@ -11,10 +14,7 @@ MKC_CHECK_DEFINES += ${m}_ENTRY:sys/queue.h
_macro.${m} = 1
.endfor
-MKC_NOAUTO.orig := ${MKC_NOAUTO}
-MKC_NOAUTO = 1
-
-.include <mkc.configure.mk>
+.include <mkc_imp.conf-cleanup.mk>
.for f in ${MKC_FEATURES}
.if defined(_macro.${f}) && !${HAVE_DEFINE.${m}_ENTRY.sys/queue.h:U0}
@@ -30,8 +30,7 @@ CFLAGS+= -DMKC_SYS_QUEUE_IS_FINE=1
.undef _macro.${m}
.endfor
-MKC_NOAUTO := ${MKC_NOAUTO.orig}
-
.undef bad
.undef _macro
-.undef MKC_NOAUTO.orig
+
+.endif # _MKC_IMP_F_SYSQUEUE_MK