summaryrefslogtreecommitdiff
path: root/scripts/mk-configure.7.in
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:48 +0200
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:48 +0200
commit8d15cbf39b8aa01eaabfa3167e6ce3dc9f9e0af8 (patch)
tree285bc54cde407bc53e4134c649569b92758ed33a /scripts/mk-configure.7.in
parent6ec061aabc159e3f37591e92fa1df407cdca6246 (diff)
Imported Upstream version 0.27.0
Diffstat (limited to 'scripts/mk-configure.7.in')
-rw-r--r--scripts/mk-configure.7.in27
1 files changed, 24 insertions, 3 deletions
diff --git a/scripts/mk-configure.7.in b/scripts/mk-configure.7.in
index 316d6ae..e9579a5 100644
--- a/scripts/mk-configure.7.in
+++ b/scripts/mk-configure.7.in
@@ -99,6 +99,11 @@ for the sample.
Commands associated with targets
.IR all ", " install ", " clean ", " cleandir ", " depend ", " test ", " installdirs ", " uninstall ", " errorcheck " and " filelist
in Makefile override the standard behaviour.
+.P
+.B NOTE:
+All targets in this list have
+.IR pre\_* ", " do\_* " and " post\_*
+counterparts. See ALLTARGETS for details.
.SS "Common variables"
The following variables control how various files are compiled/built.
.IP AR
@@ -959,19 +964,31 @@ subdirectory. Slash symbols inside <dir> are replaced with underlines.
In addition, SRCDIR_<dir:T> variable is set to ${SRCDIR_<dir>}
if ${SHORTPRJNAME} is "yes".
.IP TARGETS
-List of recursive targets supported by the project and all its subprojects.
+A list of recursive targets. "Recursive" means that the target will be called
+for all subproject recursively (See
+.BR mkc.subprj.mk " and " mkc.subdir.mk ).
.RI < "Im" >
.RI [ all ", " install ", " installdirs ", " uninstall ", " clean ", "
-.IR cleandir ", " depends ", " test ", " errorcheck ", " filelist ]
+.IR cleandir ", " depends ", " test ", " errorcheck ", " filelist ", " obj ]
By setting this variable in the Makefile one can add new targets for special
purposes, for example, static code analysis, partial builds etc.
+.IP ALLTARGETS
+A list of targets for which pre\_*, do_* and post\_* counterparts exist, for example,
+pre\_all, do\_all and post\_all. pre\_* target runs before do\_* target which in turn
+runs before post\_*. Unless action is provided for do\_* targets
+they implement the standard behaviour of
+.BR mk-configure .
+No action is provided for targets pre\_* and post\_*, so they are
+for user's extensions. The standard behaviour for ${ALLTARGETS}
+may also be extended by adding new prerequisites
+to targets do\_*.
.IP SHORTPRJNAME
If "yes", special targets with last component of the subprojects are provided.
.RI < "Im" >
.RI [ yes ]
.IP MKRELOBJDIR
If "yes", object directories
-.RI ${TOPOBJ}/ dir
+.RI ${OBJTOP}/ dir
are used. Unlike MAKEOBJDIRPREFIX object directories do not contain
top-level ${.CURDIR} in paths.
.RI < "Iu" >
@@ -1879,6 +1896,10 @@ and
.IP DPSRCS
List of source files which are needed for generating
dependencies, but are not needed in ${SRCS}.
+.IP MKDEP_CC
+Compiler passed to mkdep(1).
+.RI < "Iu" >
+.RI [ "${CC}" ].
.SH "CROSS COMPILATION"
The following variables are used for compiling software using cross-tools.
.IP MACHINE_GNU_PLATFORM