summaryrefslogtreecommitdiff
path: root/tests/pkg_config_1
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:21 +0200
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:21 +0200
commit1d3d0bb1e461a81bc1a9cd4520958bd2b1db4c7f (patch)
tree1aa5b654ab4ab52e936550463aac7e4da0aad722 /tests/pkg_config_1
Imported Upstream version 0.24.0
Diffstat (limited to 'tests/pkg_config_1')
-rw-r--r--tests/pkg_config_1/Makefile6
-rw-r--r--tests/pkg_config_1/test.mk14
2 files changed, 20 insertions, 0 deletions
diff --git a/tests/pkg_config_1/Makefile b/tests/pkg_config_1/Makefile
new file mode 100644
index 0000000..d2dcc08
--- /dev/null
+++ b/tests/pkg_config_1/Makefile
@@ -0,0 +1,6 @@
+LIB= mkc_fake
+
+PKG_CONFIG_DEPS= mkc_fake-2.0>=2.10
+
+.include "test.mk"
+.include <mkc.prog.mk>
diff --git a/tests/pkg_config_1/test.mk b/tests/pkg_config_1/test.mk
new file mode 100644
index 0000000..6fe834c
--- /dev/null
+++ b/tests/pkg_config_1/test.mk
@@ -0,0 +1,14 @@
+test:
+ @echo 'Testing ${.CURDIR}... ' 1>&2; \
+ set -e; cd ${.CURDIR}; \
+ tmp_out=${.OBJDIR}/${.CURDIR:T}.test.out; \
+ rm -f $$tmp_out; \
+ ${MAKE} ${MAKEFLAGS} all 2>&1 | grep ERROR: > $$tmp_out || true; \
+ if test -s $$tmp_out; \
+ then echo ' succeeded' 1>&2; \
+ else echo ' FAILED' 1>&2; ex=1; \
+ fi; \
+ ${MAKE} ${MAKEFLAGS} cleandir 2>&1 | grep ERROR: > $$tmp_out || true; \
+ exit $$ex
+
+CLEANFILES += ${.OBJDIR}/${.CURDIR:T}.test.out