summaryrefslogtreecommitdiff
path: root/tests/reqd_clean_cache/test.mk
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-01-05 22:42:41 +0100
committerAndrew Shadura <andrew@shadura.me>2015-07-25 14:44:33 +0200
commitc8659b636be5e763c5dc028a5db7294b1af2648c (patch)
tree7dacf7580ff8c7d8c64682eaa28350bc47fbd56e /tests/reqd_clean_cache/test.mk
parent004c4cd3db1d9ad252eccbc1e9e6c54ec61a2927 (diff)
parentaba913436a8521abe405a04ed71388989e1d646f (diff)
Imported Debian patch 0.25.0-1
Diffstat (limited to 'tests/reqd_clean_cache/test.mk')
-rw-r--r--tests/reqd_clean_cache/test.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/reqd_clean_cache/test.mk b/tests/reqd_clean_cache/test.mk
new file mode 100644
index 0000000..e5cea19
--- /dev/null
+++ b/tests/reqd_clean_cache/test.mk
@@ -0,0 +1,14 @@
+TEST_PREREQS = # empty
+
+.PHONY : test_output
+test_output :
+ @set -e; LC_ALL=C; export LC_ALL; \
+ \
+ echo =========== all ============; \
+ { ${MAKE} ${MAKEFLAGS} all 2>/dev/null || true; \
+ find ${.OBJDIR} -type f -o -type l | sort; } | \
+ env NOSORT=1 mkc_test_helper "${PREFIX}" "${.OBJDIR}"; \
+ \
+ ${MAKE} ${MAKEFLAGS} cleandir > /dev/null
+
+.include <mkc.minitest.mk>